summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-extended/sanlock/sanlock_3.8.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-extended/sanlock/sanlock_3.8.0.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/sanlock/sanlock_3.8.0.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/meta-openembedded/meta-oe/recipes-extended/sanlock/sanlock_3.8.0.bb b/meta-openembedded/meta-oe/recipes-extended/sanlock/sanlock_3.8.0.bb
index 9f7ce9c57..bf7eaf411 100644
--- a/meta-openembedded/meta-oe/recipes-extended/sanlock/sanlock_3.8.0.bb
+++ b/meta-openembedded/meta-oe/recipes-extended/sanlock/sanlock_3.8.0.bb
@@ -11,13 +11,15 @@ SECTION = "utils"
LICENSE = "LGPLv2+ & GPLv2 & GPLv2+"
LIC_FILES_CHKSUM = "file://README.license;md5=60487bf0bf429d6b5aa72b6d37a0eb22"
-SRC_URI = "git://pagure.io/sanlock.git;protocol=http"
+SRC_URI = "git://pagure.io/sanlock.git;protocol=http \
+ file://0001-sanlock-Replace-cp-a-with-cp-R-no-dereference-preser.patch \
+ "
SRCREV = "7afe0e66f5c7f24894896fad20ffa6f39733d80f"
S = "${WORKDIR}/git"
DEPENDS = "libaio util-linux"
-inherit distutils
+inherit distutils3 useradd
do_configure[noexec] = "1"
@@ -32,3 +34,11 @@ do_install_prepend () {
oe_runmake -C src DESTDIR=${D} LIBDIR=${libdir} install
cd ${S}/python
}
+
+SANLOCKGROUP ?= "sanlock"
+SANLOCKUSER ?= "sanlock"
+USERADD_PACKAGES = "${PN}"
+GROUPADD_PARAM_${PN} = "--system ${SANLOCKGROUP}"
+USERADD_PARAM_${PN} = "--system -g ${SANLOCKGROUP} -G disk \
+ --home-dir /run/${SANLOCKUSER} --no-create-home \
+ --shell /sbin/nologin ${SANLOCKUSER}"