summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-extended/socketcan
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-extended/socketcan')
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/socketcan/can-isotp_git.bb2
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/socketcan/can-utils_git.bb14
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/socketcan/canutils_4.0.6.bb4
3 files changed, 10 insertions, 10 deletions
diff --git a/meta-openembedded/meta-oe/recipes-extended/socketcan/can-isotp_git.bb b/meta-openembedded/meta-oe/recipes-extended/socketcan/can-isotp_git.bb
index 0278b5338..eed79ae7f 100644
--- a/meta-openembedded/meta-oe/recipes-extended/socketcan/can-isotp_git.bb
+++ b/meta-openembedded/meta-oe/recipes-extended/socketcan/can-isotp_git.bb
@@ -12,7 +12,7 @@ inherit module
EXTRA_OEMAKE += "KERNELDIR=${STAGING_KERNEL_DIR}"
-do_install_append() {
+do_install:append() {
install -Dm 644 ${S}/include/uapi/linux/can/isotp.h ${D}${includedir}/linux/can/isotp.h
}
diff --git a/meta-openembedded/meta-oe/recipes-extended/socketcan/can-utils_git.bb b/meta-openembedded/meta-oe/recipes-extended/socketcan/can-utils_git.bb
index 36e7d1ef5..ad7fc596e 100644
--- a/meta-openembedded/meta-oe/recipes-extended/socketcan/can-utils_git.bb
+++ b/meta-openembedded/meta-oe/recipes-extended/socketcan/can-utils_git.bb
@@ -16,7 +16,7 @@ inherit autotools pkgconfig update-alternatives
PACKAGES =+ "${PN}-access ${PN}-isotp ${PN}-j1939 ${PN}-cantest ${PN}-slcan ${PN}-log"
-FILES_${PN}-access = " \
+FILES:${PN}-access = " \
${bindir}/cangw \
${bindir}/canlogserver \
${bindir}/bcmserver \
@@ -24,24 +24,24 @@ FILES_${PN}-access = " \
${bindir}/cannelloni \
"
-FILES_${PN}-isotp = "${bindir}/isotp*"
+FILES:${PN}-isotp = "${bindir}/isotp*"
-FILES_${PN}-j1939 = " \
+FILES:${PN}-j1939 = " \
${bindir}/j* \
${bindir}/testj1939 \
"
-FILES_${PN}-cantest = " \
+FILES:${PN}-cantest = " \
${bindir}/canbusload \
${bindir}/can-calc-bit-timing \
${bindir}/canfdtest \
"
-FILES_${PN}-slcan = "${bindir}/slcan*"
+FILES:${PN}-slcan = "${bindir}/slcan*"
-FILES_${PN}-log = "${bindir}/*log*"
+FILES:${PN}-log = "${bindir}/*log*"
-ALTERNATIVE_${PN} = "candump cansend cansequence"
+ALTERNATIVE:${PN} = "candump cansend cansequence"
ALTERNATIVE_LINK_NAME[candump] = "${bindir}/candump"
ALTERNATIVE_LINK_NAME[cansend] = "${bindir}/cansend"
ALTERNATIVE_LINK_NAME[cansequence] = "${bindir}/cansequence"
diff --git a/meta-openembedded/meta-oe/recipes-extended/socketcan/canutils_4.0.6.bb b/meta-openembedded/meta-oe/recipes-extended/socketcan/canutils_4.0.6.bb
index 8b13daea1..65e1fde0b 100644
--- a/meta-openembedded/meta-oe/recipes-extended/socketcan/canutils_4.0.6.bb
+++ b/meta-openembedded/meta-oe/recipes-extended/socketcan/canutils_4.0.6.bb
@@ -19,10 +19,10 @@ S = "${WORKDIR}/git"
inherit autotools pkgconfig
# Busybox ip doesn't support can interface configuration, use the real thing
-RDEPENDS_${PN} += "iproute2"
+RDEPENDS:${PN} += "iproute2"
ALTERNATIVE_PRIORITY = "90"
-ALTERNATIVE_${PN} = "candump cansend cansequence"
+ALTERNATIVE:${PN} = "candump cansend cansequence"
ALTERNATIVE_LINK_NAME[candump] = "${bindir}/candump"
ALTERNATIVE_LINK_NAME[cansend] = "${bindir}/cansend"
ALTERNATIVE_LINK_NAME[cansequence] = "${bindir}/cansequence"