summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/meta-openembedded/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb b/meta-openembedded/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb
index 1863f95f0..bcc85157c 100644
--- a/meta-openembedded/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb
+++ b/meta-openembedded/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb
@@ -7,11 +7,11 @@ LIC_FILES_CHKSUM = " \
"
DEPENDS = "python3 glib-2.0 pango giflib tiff libxml2 jpeg libtool uthash gettext-native"
-DEPENDS_append_class-target = " libxi"
+DEPENDS:append:class-target = " libxi"
inherit autotools pkgconfig python3native features_check gettext gtk-icon-cache mime mime-xdg
-REQUIRED_DISTRO_FEATURES_append_class-target = " x11"
+REQUIRED_DISTRO_FEATURES:append:class-target = " x11"
# tag 20190801
SRCREV = "ac635b818e38ddb8e7e2e1057330a32b4e25476e"
@@ -21,12 +21,12 @@ SRC_URI = "git://github.com/${BPN}/${BPN}.git \
S = "${WORKDIR}/git"
EXTRA_OECONF += "--without-libuninameslist --enable-python-scripting --enable-python-extension"
-EXTRA_OECONF_append_class-native = " with_x=no"
+EXTRA_OECONF:append:class-native = " with_x=no"
LDFLAGS += "-lpython${PYTHON_BASEVERSION}${PYTHON_ABI}"
BUILD_LDFLAGS += "-lpython${PYTHON_BASEVERSION}${PYTHON_ABI}"
-#do_configure_prepend() {
+#do_configure:prepend() {
# uthash sources are expected in uthash/src
# mkdir -p ${S}/uthash/src
# cp ${STAGING_INCDIR}/ut*.h ${S}/uthash/src
@@ -34,14 +34,14 @@ BUILD_LDFLAGS += "-lpython${PYTHON_BASEVERSION}${PYTHON_ABI}"
PACKAGES =+ "${PN}-python"
-FILES_${PN} += " \
+FILES:${PN} += " \
${datadir}/appdata \
${datadir}/metainfo \
${datadir}/mime \
"
-FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR} ${datadir}/${BPN}/python"
-RDEPENDS_${PN}-python = "python3"
+FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR} ${datadir}/${BPN}/python"
+RDEPENDS:${PN}-python = "python3"
# for e.g kde's oxygen-fonts
BBCLASSEXTEND = "native"