summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-security/nmap/nmap_7.80.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-security/nmap/nmap_7.80.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-security/nmap/nmap_7.80.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta-openembedded/meta-oe/recipes-security/nmap/nmap_7.80.bb b/meta-openembedded/meta-oe/recipes-security/nmap/nmap_7.80.bb
index c76d2324e..17bc40911 100644
--- a/meta-openembedded/meta-oe/recipes-security/nmap/nmap_7.80.bb
+++ b/meta-openembedded/meta-oe/recipes-security/nmap/nmap_7.80.bb
@@ -50,9 +50,11 @@ do_configure() {
}
do_install_append() {
- if [ -f "${D}${bindir}/ndiff" ]; then
- sed -i 's@^#!.*$@#!/usr/bin/env python3@g' ${D}${bindir}/ndiff
- fi
+ for f in ndiff uninstall_ndiff; do
+ if [ -f ${D}${bindir}/$f ]; then
+ sed -i 's@^#!.*$@#!/usr/bin/env python3@g' ${D}${bindir}/$f
+ fi
+ done
}
FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR} ${datadir}/ncat"