summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/libgit2/libgit2_1.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/libgit2/libgit2_1.1.0.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/libgit2/libgit2_1.1.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/libgit2/libgit2_1.1.0.bb b/meta-openembedded/meta-oe/recipes-support/libgit2/libgit2_1.1.0.bb
new file mode 100644
index 000000000..2bbf59ea7
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/libgit2/libgit2_1.1.0.bb
@@ -0,0 +1,22 @@
+SUMMARY = "the Git linkable library"
+HOMEPAGE = "http://libgit2.github.com/"
+LICENSE = "GPL-2.0-with-GCC-exception & MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5b002a195fb7ea2d8d583f07eaff3a8e"
+
+DEPENDS = "curl openssl zlib libssh2 libgcrypt libpcre2"
+
+SRC_URI = "git://github.com/libgit2/libgit2.git;branch=maint/v1.1"
+SRCREV = "7f4fa178629d559c037a1f72f79f79af9c1ef8ce"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+EXTRA_OECMAKE = "\
+ -DBUILD_CLAR=OFF \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DLIB_INSTALL_DIR=${libdir} \
+ -DREGEX_BACKEND='pcre2' \
+"
+
+BBCLASSEXTEND = "native"