summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/libgpiod/libgpiod_1.6.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/libgpiod/libgpiod_1.6.2.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/libgpiod/libgpiod_1.6.2.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/libgpiod/libgpiod_1.6.2.bb b/meta-openembedded/meta-oe/recipes-support/libgpiod/libgpiod_1.6.2.bb
index c0cf54589..e6b6476e2 100644
--- a/meta-openembedded/meta-oe/recipes-support/libgpiod/libgpiod_1.6.2.bb
+++ b/meta-openembedded/meta-oe/recipes-support/libgpiod/libgpiod_1.6.2.bb
@@ -4,11 +4,14 @@ AUTHOR = "Bartosz Golaszewski <bgolaszewski@baylibre.com>"
LICENSE = "LGPLv2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de"
-SRC_URI = "https://www.kernel.org/pub/software/libs/${BPN}/${BP}.tar.xz"
+SRC_URI = "https://www.kernel.org/pub/software/libs/${BPN}/${BP}.tar.xz \
+ file://run-ptest \
+"
+
SRC_URI[md5sum] = "4765470becb619fead3cdaeac61b9a77"
SRC_URI[sha256sum] = "c601e71846f5ab140c83bc757fdd62a4fda24a9cee39cc5e99c96ec2bf1b06a9"
-inherit autotools pkgconfig python3native
+inherit autotools pkgconfig python3native ptest
PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev glib-2.0 catch2"
PACKAGECONFIG[cxx] = "--enable-bindings-cxx,--disable-bindings-cxx"
@@ -31,3 +34,10 @@ PACKAGES =+ "${PN}-python"
FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
RRECOMMENDS_PYTHON = "${@bb.utils.contains('PACKAGECONFIG', 'python3', '${PN}-python', '',d)}"
RRECOMMENDS_${PN}-python += "${RRECOMMENDS_PYTHON}"
+
+PACKAGECONFIG_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'tests', '', d)}"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp ${B}/tests/.libs/gpiod-test ${D}${PTEST_PATH}/tests/
+}