summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/portaudio/portaudio-v19_19.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/portaudio/portaudio-v19_19.7.0.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/portaudio/portaudio-v19_19.7.0.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/portaudio/portaudio-v19_19.7.0.bb b/meta-openembedded/meta-oe/recipes-support/portaudio/portaudio-v19_19.7.0.bb
new file mode 100644
index 000000000..3a0f7894f
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/portaudio/portaudio-v19_19.7.0.bb
@@ -0,0 +1,32 @@
+SUMMARY = "A portable audio library"
+SECTION = "libs/multimedia"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=26107732c2ab637c5710446fcfaf02df"
+
+PV = "v190700"
+
+SRC_URI = " \
+ git://github.com/PortAudio/portaudio.git \
+ file://0001-Find-jack.patch \
+"
+SRCREV = "147dd722548358763a8b649b3e4b41dfffbcfbb6"
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+PACKAGECONFIG ??= "alsa jack"
+PACKAGECONFIG[alsa] = ",,alsa-lib"
+PACKAGECONFIG[jack] = ",,jack"
+PACKAGECONFIG[examples] = "-DPA_BUILD_EXAMPLES=ON,-DPA_BUILD_EXAMPLES=OFF"
+
+do_install_append() {
+ if [ -d ${B}/examples ]; then
+ install -d ${D}${bindir}
+ for example in ${B}/examples/pa*; do
+ install -m755 $example ${D}${bindir}/
+ done
+ fi
+}
+
+FILES_SOLIBSDEV = ""
+FILES_${PN} += "${libdir}/libportaudio.so"