summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/satyr/satyr_0.37.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/satyr/satyr_0.37.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/satyr/satyr_0.37.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/satyr/satyr_0.37.bb b/meta-openembedded/meta-oe/recipes-support/satyr/satyr_0.37.bb
new file mode 100644
index 000000000..4630eb021
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/satyr/satyr_0.37.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Satyr is a collection of low-level algorithms for program \
+failure processing, analysis, and reporting supporting kernel space, user \
+space, Python, and Java programs"
+
+HOMEPAGE = "https://github.com/abrt/satyr"
+LICENSE = "GPLv2"
+
+inherit autotools-brokensep python3native pkgconfig
+
+SRC_URI = "git://github.com/abrt/satyr.git \
+ file://0002-fix-compile-failure-against-musl-C-library.patch \
+"
+SRCREV = "4a7d0a31cdeee23bb13739f57926188a795bdf25"
+S = "${WORKDIR}/git"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+DEPENDS += " \
+ gdb \
+ gperf-native \
+ json-c \
+ nettle \
+ glib-2.0 \
+"
+
+PACKAGES += "python3-${BPN}"
+FILES_python3-${BPN} = "${PYTHON_SITEPACKAGES_DIR}/${BPN}"
+
+PACKAGECONFIG ??= "python3 rpm"
+PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
+PACKAGECONFIG[rpm] = "--with-rpm, --without-rpm, rpm"
+
+do_configure_prepend() {
+ ${S}/gen-version
+}