summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/zbar/zbar_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/zbar/zbar_git.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/zbar/zbar_git.bb29
1 files changed, 14 insertions, 15 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/zbar/zbar_git.bb b/meta-openembedded/meta-oe/recipes-support/zbar/zbar_git.bb
index dae912252..a33aa2c96 100644
--- a/meta-openembedded/meta-oe/recipes-support/zbar/zbar_git.bb
+++ b/meta-openembedded/meta-oe/recipes-support/zbar/zbar_git.bb
@@ -10,8 +10,8 @@ LICENSE = "LGPL-2.1"
LIC_FILES_CHKSUM = "file://LICENSE.md;md5=5e9ee833a2118adc7d8b5ea38e5b1cef"
SRC_URI = "git://github.com/mchehab/zbar.git;branch=master \
- file://0001-qt-Create-subdir-in-Makefile.patch \
- file://0002-zbarcam-Create-subdir-in-Makefile.patch \
+ file://0001-qt-Create-subdir-in-Makefile.patch \
+ file://0002-zbarcam-Create-subdir-in-Makefile.patch \
"
SRCREV = "89e7900d85dd54ef351a7ed582aec6a5a5d7fa37"
@@ -21,15 +21,15 @@ PV = "0.23.1+git${SRCPV}"
DEPENDS += "xmlto-native"
PACKAGECONFIG ??= "\
- ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \
"
PACKAGECONFIG ??= "video python3"
inherit autotools pkgconfig gettext \
- ${@bb.utils.contains('PACKAGECONFIG', 'python3', 'python3native', '', d)} \
- ${@bb.utils.contains('PACKAGECONFIG', 'gtk3', 'gobject-introspection', '', d)} \
- ${@bb.utils.contains('PACKAGECONFIG', 'qt5', 'qmake5_paths', '', d)}
+ ${@bb.utils.contains('PACKAGECONFIG', 'python3', 'python3native', '', d)} \
+ ${@bb.utils.contains('PACKAGECONFIG', 'gtk3', 'gobject-introspection', '', d)} \
+ ${@bb.utils.contains('PACKAGECONFIG', 'qt5', 'qmake5_paths', '', d)}
PACKAGECONFIG[x11] = "--with-x, --without-x, libxv"
PACKAGECONFIG[video] = "--enable-video, --disable-video, v4l-utils libv4l"
@@ -40,20 +40,19 @@ PACKAGECONFIG[qt5] = "--with-qt5, --without-qt5, qtbase qtbase-native qtx11extra
PACKAGECONFIG[imagemagick] = "--with-imagemagick, --without-imagemagick, imagemagick"
FILES_${PN} += "${bindir} \
- ${@bb.utils.contains('DEPENDS', 'python3-native', '${libdir}', '', d)} \
+ ${@bb.utils.contains('DEPENDS', 'python3-native', '${libdir}', '', d)} \
"
CPPFLAGS_append = "\
- ${@bb.utils.contains('PACKAGECONFIG', 'qt5', '\
- -I${STAGING_INCDIR}/QtX11Extras \
- -I${STAGING_INCDIR}/dbus-1.0 \
- -I${STAGING_LIBDIR}/dbus-1.0/include \
- ', '', d)} \
+ ${@bb.utils.contains('PACKAGECONFIG', 'qt5', '\
+ -I${STAGING_INCDIR}/QtX11Extras \
+ -I${STAGING_INCDIR}/dbus-1.0 \
+ -I${STAGING_LIBDIR}/dbus-1.0/include \
+ ', '', d)} \
"
TARGET_CXXFLAGS_append = " -fPIC"
-do_prepare_recipe_sysroot_gettext() {
- install -m 755 ${STAGING_DATADIR_NATIVE}/gettext/ABOUT-NLS ${S}/
+do_configure_prepend() {
+ install -m 755 ${STAGING_DATADIR_NATIVE}/gettext/ABOUT-NLS ${S}/
}
-addtask do_prepare_recipe_sysroot_gettext after do_prepare_recipe_sysroot before do_configure \ No newline at end of file