summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-test/fwts/fwts_21.03.00.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-test/fwts/fwts_21.03.00.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-test/fwts/fwts_21.03.00.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-test/fwts/fwts_21.03.00.bb b/meta-openembedded/meta-oe/recipes-test/fwts/fwts_21.03.00.bb
new file mode 100644
index 000000000..aa7d422f7
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-test/fwts/fwts_21.03.00.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Firmware testsuite"
+DESCRIPTION = "The tool fwts comprises of over fifty tests that are designed to exercise and test different aspects of a machine's firmware. Many of these tests need super user access to read BIOS data and ACPI tables, so the tool requires running with super user privileges (e.g. with sudo)."
+HOMEPAGE = "https://wiki.ubuntu.com/Kernel/Reference/fwts"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=16;md5=31da590f3e9f3bd34dcdb9e4db568519"
+
+SRC_URI = "http://fwts.ubuntu.com/release/fwts-V${PV}.tar.gz;subdir=${BP} \
+ file://0001-Add-correct-printf-qualifier-for-off_t.patch \
+ file://0002-Include-poll.h-instead-of-deprecated-sys-poll.h.patch \
+ file://0003-Remove-Werror-from-build.patch \
+ file://0004-Define-__SWORD_TYPE-if-not-defined-by-libc.patch \
+ file://0005-Undefine-PAGE_SIZE.patch \
+ file://0006-use-intptr_t-to-fix-pointer-to-int-cast-issues.patch \
+ "
+SRC_URI[sha256sum] = "c22dcba2572e4237bf2fe9ab579e195cf051d3a99b2c07ab58f757cae02d24fb"
+
+COMPATIBLE_HOST = "(i.86|x86_64|aarch64|powerpc64).*-linux"
+
+DEPENDS = "libpcre glib-2.0 dtc bison-native libbsd"
+DEPENDS_append_libc-musl = " libexecinfo"
+
+# Use brokensep for now (https://github.com/ColinIanKing/fwts/issues/2)
+inherit autotools-brokensep bash-completion pkgconfig
+
+LDFLAGS_append_libc-musl = " -lexecinfo"
+
+FILES_${PN} += "${libdir}/fwts/lib*${SOLIBS}"
+FILES_${PN}-dev += "${libdir}/fwts/lib*${SOLIBSDEV} ${libdir}/fwts/lib*.la"
+FILES_${PN}-staticdev += "${libdir}/fwts/lib*a"
+
+RDEPENDS_${PN} += "dtc"