summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-bsp/libekb/libekb_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-bsp/libekb/libekb_git.bb')
-rw-r--r--meta-openpower/recipes-bsp/libekb/libekb_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-openpower/recipes-bsp/libekb/libekb_git.bb b/meta-openpower/recipes-bsp/libekb/libekb_git.bb
new file mode 100644
index 000000000..ac650a4a8
--- /dev/null
+++ b/meta-openpower/recipes-bsp/libekb/libekb_git.bb
@@ -0,0 +1,27 @@
+HOMEPAGE = "https://github.com/open-power/libekb_p10"
+
+SUMMARY = "Hardware Procedure Framework"
+DESCRIPTION = "Provides infrastructure to run hardware procedures"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+S = "${WORKDIR}/git"
+
+require recipes-bsp/ekb/ekb.inc
+
+inherit autotools \
+ python3native \
+ perlnative
+
+SRCREV_FORMAT = "libekb_ekb"
+
+SRCREV_libekb = "a68c2f610243d3f128f561c4451135241aedbf6b"
+SRCREV_ekb = "${EKB_REV}"
+
+SRC_URI = "git://git@github.com/open-power/libekb_p10;branch="main";name=libekb \
+ ${EKB_URI};name=ekb;destsuffix=git/ekb \
+ "
+
+DEPENDS = "pdbg libxml-simple-perl-native"