summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-bsp/pdata/pdata_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-bsp/pdata/pdata_git.bb')
-rw-r--r--meta-openpower/recipes-bsp/pdata/pdata_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-openpower/recipes-bsp/pdata/pdata_git.bb b/meta-openpower/recipes-bsp/pdata/pdata_git.bb
new file mode 100644
index 000000000..50f406db1
--- /dev/null
+++ b/meta-openpower/recipes-bsp/pdata/pdata_git.bb
@@ -0,0 +1,27 @@
+HOMEPAGE = "https://github.com/open-power/pdata/"
+
+SUMMARY = "POWER Host data management"
+DESCRIPTION = "Devicetree based POWER host data management"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+S = "${WORKDIR}/git"
+
+inherit autotools \
+ perlnative
+
+SRC_URI = "git://git@github.com/open-power/pdata;branch="main""
+SRCREV = "a617306c59c81b879aeb1a3d271b5f633895efd0"
+
+DEPENDS = "pdbg \
+ libxml-simple-perl-native \
+ libxml-libxml-perl-native \
+ ekb-native \
+ autoconf-archive"
+
+PDATA_CONFARG = "CHIP=p10"
+EXTRA_OECONF = "--enable-gen_attrsinfo ${PDATA_CONFARG}"
+
+EXTRA_OEMAKE = "EKB=${STAGING_DATADIR_NATIVE}/ekb/"