summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/debug
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-phosphor/debug')
-rw-r--r--meta-openpower/recipes-phosphor/debug/openpower-debug-collector-systemd-links.inc4
-rw-r--r--meta-openpower/recipes-phosphor/debug/openpower-debug-collector.inc2
-rw-r--r--meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb7
3 files changed, 7 insertions, 6 deletions
diff --git a/meta-openpower/recipes-phosphor/debug/openpower-debug-collector-systemd-links.inc b/meta-openpower/recipes-phosphor/debug/openpower-debug-collector-systemd-links.inc
index 9c522c1cd..b252e6c11 100644
--- a/meta-openpower/recipes-phosphor/debug/openpower-debug-collector-systemd-links.inc
+++ b/meta-openpower/recipes-phosphor/debug/openpower-debug-collector-systemd-links.inc
@@ -15,7 +15,7 @@ pkg_postinst:${PN}:append() {
TARGET="../openpower-debug-collector-watchdog@.service"
ln -s $TARGET $LINK
- if [ "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}" != 'phal' ]; then
+ if [ "${@bb.utils.filter('MACHINE_FEATURES', 'phal', d)}" != 'phal' ]; then
LINK="$D$systemd_system_unitdir/obmc-host-timeout@0.target.wants/openpower-debug-collector-watchdog-timeout@0.service"
TARGET="../openpower-debug-collector-watchdog-timeout@.service"
ln -s $TARGET $LINK
@@ -29,7 +29,7 @@ pkg_prerm:${PN}:append() {
fi
LINK="$D$systemd_system_unitdir/obmc-host-timeout@0.target.wants/openpower-debug-collector-watchdog@0.service"
rm $LINK
- if [ "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}" != 'phal' ]; then
+ if [ "${@bb.utils.filter('MACHINE_FEATURES', 'phal', d)}" != 'phal' ]; then
LINK="$D$systemd_system_unitdir/obmc-host-timeout@0.target.wants/openpower-debug-collector-watchdog-timeout@0.service"
rm $LINK
fi
diff --git a/meta-openpower/recipes-phosphor/debug/openpower-debug-collector.inc b/meta-openpower/recipes-phosphor/debug/openpower-debug-collector.inc
index efeaf1f3d..6d8f3f9fb 100644
--- a/meta-openpower/recipes-phosphor/debug/openpower-debug-collector.inc
+++ b/meta-openpower/recipes-phosphor/debug/openpower-debug-collector.inc
@@ -2,4 +2,4 @@ HOMEPAGE = "https://github.com/openbmc/openpower-debug-collector"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI += "git://github.com/openbmc/openpower-debug-collector"
-SRCREV = "9b6f8474a4e33dbfda233dedceedf4c030ffd0ec"
+SRCREV = "2bd4621871408c14728c9f90eb9ebf6552aa9fe7"
diff --git a/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb b/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb
index 68965af0a..bcf356eee 100644
--- a/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb
+++ b/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb
@@ -4,7 +4,7 @@ DESCRIPTION = "Application to log error during host checkstop and watchdog timeo
PR = "r1"
PV = "1.0+git${SRCPV}"
-inherit meson \
+inherit pkgconfig meson \
obmc-phosphor-systemd \
python3native \
phosphor-dbus-yaml
@@ -16,6 +16,7 @@ DEPENDS += " \
phosphor-logging \
${PYTHON_PN}-sdbus++-native \
cli11 \
+ ipl \
"
S = "${WORKDIR}/git"
@@ -24,7 +25,7 @@ S = "${WORKDIR}/git"
APPS = " \
checkstop \
watchdog \
- ${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', '', 'watchdog-timeout', d)} \
+ ${@bb.utils.contains('MACHINE_FEATURES', 'phal', '', 'watchdog-timeout', d)} \
"
DEBUG_TMPL = "openpower-debug-collector-{0}@.service"
@@ -34,4 +35,4 @@ SYSTEMD_SERVICE:${PN} += "${@compose_list(d, 'DEBUG_TMPL', 'APPS')}"
DEPENDS:remove:class-native = "phosphor-logging"
# Do not depend on phosphor-logging for native SDK build
-DEPENDS:remove:class-nativesdk = "phosphor-logging"
+DEPENDS:remove:class-nativesdk = "phosphor-logging ipl"