summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/occ
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-phosphor/occ')
-rw-r--r--meta-openpower/recipes-phosphor/occ/openpower-occ-control.inc2
-rw-r--r--meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb14
2 files changed, 8 insertions, 8 deletions
diff --git a/meta-openpower/recipes-phosphor/occ/openpower-occ-control.inc b/meta-openpower/recipes-phosphor/occ/openpower-occ-control.inc
index 8ce44fce5..93c2ae5bd 100644
--- a/meta-openpower/recipes-phosphor/occ/openpower-occ-control.inc
+++ b/meta-openpower/recipes-phosphor/occ/openpower-occ-control.inc
@@ -2,4 +2,4 @@ HOMEPAGE = "https://github.com/openbmc/openpower-occ-control"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI += "git://github.com/openbmc/openpower-occ-control"
-SRCREV = "ff7afd98651862b9a78b53ad0ba4c3b085e4fbe4"
+SRCREV = "a7b74dc31001884243556e4433d0bbfda3c09083"
diff --git a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
index 440829175..804084e1d 100644
--- a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
+++ b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "https://github.com/openbmc/openpower-occ-control"
PR = "r1"
PV = "1.0+git${SRCPV}"
-inherit autotools \
+inherit meson \
pkgconfig \
obmc-phosphor-dbus-service \
python3native \
@@ -39,11 +39,11 @@ DEPENDS += " \
RDEPENDS:${PN} += "phosphor-state-manager-obmc-targets"
-EXTRA_OECONF = " \
- YAML_PATH=${STAGING_DATADIR_NATIVE}/${PN} \
- PS_DERATING_FACTOR=${POWER_SUPPLY_DERATING_FACTOR} \
+EXTRA_OEMESON = " \
+ -Dyamldir=${STAGING_DATADIR_NATIVE}/${PN} \
+ -Dps-derating-factor=${POWER_SUPPLY_DERATING_FACTOR} \
"
-EXTRA_OECONF:append = "${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'i2c-occ', ' --enable-i2c-occ', '', d)}"
+EXTRA_OEMESON:append = "${@bb.utils.contains('MACHINE_FEATURES', 'i2c-occ', ' -Di2c-occ=enabled', '', d)}"
OCC_ENABLE = "enable"
OCC_DISABLE = "disable"
@@ -91,8 +91,8 @@ RDEPENDS:${PN}:remove:class-nativesdk += "phosphor-state-manager-obmc-targets"
# Provide a means to enable/disable install_error_yaml feature
PACKAGECONFIG ??= "install_error_yaml"
PACKAGECONFIG[install_error_yaml] = "\
- --enable-install_error_yaml,\
- --disable-install_error_yaml,\
+ -Dinstall-error-yaml=enabled,\
+ -Dinstall-error-yaml=disabled,\
,\
"