summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-phosphor')
-rw-r--r--meta-openpower/recipes-phosphor/flash/host-fw_git.bb33
-rw-r--r--meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb2
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control_git.bb2
-rw-r--r--meta-openpower/recipes-phosphor/network/first-boot-set-hostname/first-boot-set-hostname.service1
-rw-r--r--meta-openpower/recipes-phosphor/network/first-boot-set-hostname/first-boot-set-hostname.sh3
-rwxr-xr-xmeta-openpower/recipes-phosphor/network/first-boot-set-mac/first-boot-set-mac.sh4
-rw-r--r--meta-openpower/recipes-phosphor/network/first-boot-set-mac/first-boot-set-mac@.service1
7 files changed, 42 insertions, 4 deletions
diff --git a/meta-openpower/recipes-phosphor/flash/host-fw_git.bb b/meta-openpower/recipes-phosphor/flash/host-fw_git.bb
new file mode 100644
index 000000000..00fc1fd59
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/flash/host-fw_git.bb
@@ -0,0 +1,33 @@
+SUMMARY = "OpenPOWER Host Firmware Image"
+DESCRIPTION = "Adds the OpenPOWER Host Firmware image to the BMC image"
+PR = "r1"
+
+inherit allarch
+
+HOST_FW_LICENSE ?= "Apache-2.0"
+HOST_FW_LIC_FILES_CHKSUM ?= "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+HOST_FW_SRC_URI ?= ""
+
+LICENSE = "${HOST_FW_LICENSE}"
+LIC_FILES_CHKSUM = "${HOST_FW_LIC_FILES_CHKSUM}"
+SRC_URI = "${HOST_FW_SRC_URI}"
+
+DEPENDS = "squashfs-tools-native"
+
+S = "${WORKDIR}"
+B = "${WORKDIR}/build"
+do_compile[cleandirs] = "${B}"
+
+do_compile() {
+ if [ -n "${HOST_FW_SRC_URI}" ]; then
+ unsquashfs -d ${B}/squashfs-root ${S}/pnor.xz.squashfs
+ fi
+}
+
+do_install() {
+ install -d ${D}${datadir}/${BPN}
+
+ if [ -n "${HOST_FW_SRC_URI}" ]; then
+ install -m 0440 ${B}/squashfs-root/* ${D}${datadir}/${BPN}
+ fi
+}
diff --git a/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb b/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
index a59bcac19..093a7adcf 100644
--- a/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
+++ b/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
@@ -39,7 +39,7 @@ S = "${WORKDIR}/git"
SRC_URI += "git://github.com/openbmc/openpower-pnor-code-mgmt"
-SRCREV = "b41a57d52c6e5f6673b784a7a94a8dec0787770b"
+SRCREV = "85f25407598494d8f91890df5152501680a067dd"
DBUS_SERVICE_${PN} += "org.open_power.Software.Host.Updater.service"
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index 33ac60c6c..a72adb66e 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -11,7 +11,7 @@ inherit autotools obmc-phosphor-utils pkgconfig pythonnative
inherit systemd
SRC_URI += "git://github.com/openbmc/openpower-proc-control"
-SRCREV = "60db8b147dad15890ffed21230537cd8d4898efc"
+SRCREV = "22a057ed88f0f68aca521cf8e239413113b31932"
DEPENDS += " \
autoconf-archive-native \
diff --git a/meta-openpower/recipes-phosphor/network/first-boot-set-hostname/first-boot-set-hostname.service b/meta-openpower/recipes-phosphor/network/first-boot-set-hostname/first-boot-set-hostname.service
index e58a04629..22bb80c10 100644
--- a/meta-openpower/recipes-phosphor/network/first-boot-set-hostname/first-boot-set-hostname.service
+++ b/meta-openpower/recipes-phosphor/network/first-boot-set-hostname/first-boot-set-hostname.service
@@ -1,5 +1,6 @@
[Unit]
Description=Init BMC Hostname
+ConditionPathExists=!/var/lib/first-boot-set-hostname
Wants=op-vpd-parser.service
After=op-vpd-parser.service
diff --git a/meta-openpower/recipes-phosphor/network/first-boot-set-hostname/first-boot-set-hostname.sh b/meta-openpower/recipes-phosphor/network/first-boot-set-hostname/first-boot-set-hostname.sh
index 62284d16b..eaabb0a17 100644
--- a/meta-openpower/recipes-phosphor/network/first-boot-set-hostname/first-boot-set-hostname.sh
+++ b/meta-openpower/recipes-phosphor/network/first-boot-set-hostname/first-boot-set-hostname.sh
@@ -81,4 +81,5 @@ sync_hostname() {
sync_hostname
-systemctl --no-reload disable first-boot-set-hostname.service
+# Prevent start at next boot time
+touch "/var/lib/first-boot-set-hostname"
diff --git a/meta-openpower/recipes-phosphor/network/first-boot-set-mac/first-boot-set-mac.sh b/meta-openpower/recipes-phosphor/network/first-boot-set-mac/first-boot-set-mac.sh
index da1b305d4..63a4ad710 100755
--- a/meta-openpower/recipes-phosphor/network/first-boot-set-mac/first-boot-set-mac.sh
+++ b/meta-openpower/recipes-phosphor/network/first-boot-set-mac/first-boot-set-mac.sh
@@ -79,4 +79,6 @@ fi
sync_mac $1
-systemctl --no-reload disable first-boot-set-mac@${1}.service
+# Prevent start at next boot time
+mkdir -p "/var/lib/first-boot-set-mac"
+touch "/var/lib/first-boot-set-mac/${1}"
diff --git a/meta-openpower/recipes-phosphor/network/first-boot-set-mac/first-boot-set-mac@.service b/meta-openpower/recipes-phosphor/network/first-boot-set-mac/first-boot-set-mac@.service
index 8986efd46..3ff5fc180 100644
--- a/meta-openpower/recipes-phosphor/network/first-boot-set-mac/first-boot-set-mac@.service
+++ b/meta-openpower/recipes-phosphor/network/first-boot-set-mac/first-boot-set-mac@.service
@@ -1,5 +1,6 @@
[Unit]
Description=Init BMC MAC address for NIC %I
+ConditionPathExists=!/var/lib/first-boot-set-mac/%i
Wants=mapper-wait@-xyz-openbmc_project-inventory.service
After=mapper-wait@-xyz-openbmc_project-inventory.service
Wants=mapper-wait@-xyz-openbmc_project-network-%i.service