summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-core/os-release/os-release.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-core/os-release/os-release.bbappend')
-rw-r--r--meta-phosphor/recipes-core/os-release/os-release.bbappend4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-core/os-release/os-release.bbappend b/meta-phosphor/recipes-core/os-release/os-release.bbappend
index de9a02f27..7e90ab3fb 100644
--- a/meta-phosphor/recipes-core/os-release/os-release.bbappend
+++ b/meta-phosphor/recipes-core/os-release/os-release.bbappend
@@ -5,9 +5,11 @@
# and pasting into another recipe ensure it is understood
# what that means!
+OS_RELEASE_ROOTPATH ?= "${COREBASE}"
+
def run_git(d, cmd):
try:
- oeroot = d.getVar('COREBASE', True)
+ oeroot = d.getVar('OS_RELEASE_ROOTPATH', True)
return bb.process.run(("export PSEUDO_DISABLED=1; " +
"git --work-tree %s --git-dir %s/.git %s")
% (oeroot, oeroot, cmd))[0].strip('\n')