summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-extended/stdplus
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-extended/stdplus')
-rw-r--r--meta-phosphor/recipes-extended/stdplus/stdplus_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-extended/stdplus/stdplus_git.bb b/meta-phosphor/recipes-extended/stdplus/stdplus_git.bb
new file mode 100644
index 000000000..4b5db3cb8
--- /dev/null
+++ b/meta-phosphor/recipes-extended/stdplus/stdplus_git.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Common C++ functions"
+DESCRIPTION = "Common C++ functions."
+HOMEPAGE = "http://github.com/openbmc/stdplus"
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+inherit autotools pkgconfig
+
+DEPENDS += " \
+ autoconf-archive-native \
+ "
+
+EXTRA_OECONF_append += " \
+ --disable-examples \
+ --disable-tests \
+ "
+
+SRC_URI += "git://github.com/openbmc/stdplus"
+SRCREV = "15982f6c0a252bc3642efb2df5d3c209e535c4fa"
+
+S = "${WORKDIR}/git"