summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper-config-native.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dbus/phosphor-mapper-config-native.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-mapper-config-native.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper-config-native.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper-config-native.bb
index dcc5bd3c1..9e2f43f24 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper-config-native.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper-config-native.bb
@@ -24,10 +24,17 @@ DEPENDS += "${PHOSPHOR_MAPPER_CONFIGS}"
# Add path namespaces to be monitored.
PHOSPHOR_MAPPER_NAMESPACE = ""
+# Add services to be monitored.
+PHOSPHOR_MAPPER_SERVICE = ""
+
# Add interfaces to be monitored.
PHOSPHOR_MAPPER_INTERFACE = ""
+# Blacklist services from being monitored.
+PHOSPHOR_MAPPER_SERVICE_BLACKLIST = ""
+
do_install() {
install -d ${D}/${namespace_dir}
install -d ${D}/${interface_dir}
+ install -d ${D}/${serviceblacklist_dir}
}