summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb b/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb
index b14f154ff..cce6fdef0 100644
--- a/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb
@@ -5,14 +5,14 @@ PV = "1.0+git${SRCPV}"
require ${PN}.inc
-inherit autotools pkgconfig python3native
+inherit meson pkgconfig python3native
inherit obmc-phosphor-dbus-service obmc-phosphor-systemd
PACKAGECONFIG ??= ""
-PACKAGECONFIG[use-json] = "--enable-use-json, --disable-use-json"
-PACKAGECONFIG[use-lamp-test] = "--enable-use-lamp-test, --disable-use-lamp-test"
-PACKAGECONFIG[monitor-operational-status] = "--enable-monitor-operational-status, \
- --disable-monitor-operational-status"
+PACKAGECONFIG[use-json] = "-Duse-json=enabled, -Duse-json=disabled"
+PACKAGECONFIG[use-lamp-test] = "-Duse-lamp-test=enabled, -Duse-lamp-test=disabled"
+PACKAGECONFIG[monitor-operational-status] = "-Dmonitor-operational-status=enabled, \
+ -Dmonitor-operational-status=disabled"
SYSTEMD_PACKAGES = "${PN} ${PN}-faultmonitor"
PACKAGE_BEFORE_PN += "${PN}-faultmonitor"