summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb25
1 files changed, 11 insertions, 14 deletions
diff --git a/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb b/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
index 630dc6bcd..df85547f0 100644
--- a/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
+++ b/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
@@ -6,38 +6,35 @@ PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
-inherit autotools pkgconfig
+inherit meson pkgconfig
inherit python3native
inherit systemd
SRC_URI += "git://github.com/openbmc/phosphor-networkd"
-SRCREV = "de433b74ec5bce22043ea44c55e83d9be3dc5372"
+SRCREV = "bdbbfb628fad902e3f72e393e6d1f639f8b8c92f"
DEPENDS += "systemd"
-DEPENDS += "autoconf-archive-native"
DEPENDS += "sdbusplus ${PYTHON_PN}-sdbus++-native"
DEPENDS += "sdeventplus"
DEPENDS += "phosphor-dbus-interfaces"
DEPENDS += "phosphor-logging"
DEPENDS += "libnl"
DEPENDS += "stdplus"
-DEPENDS += "nlohmann-json"
PACKAGECONFIG ??= "uboot-env default-link-local-autoconf default-ipv6-accept-ra"
UBOOT_ENV_RDEPENDS = "${@d.getVar('PREFERRED_PROVIDER_u-boot-fw-utils', True) or 'u-boot-fw-utils'}"
-PACKAGECONFIG[uboot-env] = "--with-uboot-env,--without-uboot-env,,${UBOOT_ENV_RDEPENDS}"
-PACKAGECONFIG[default-link-local-autoconf] = "--enable-link-local-autoconfiguration,--disable-link-local-autoconfiguration,,"
-PACKAGECONFIG[default-ipv6-accept-ra] = "--enable-ipv6-accept-ra,--disable-ipv6-accept-ra,,"
-PACKAGECONFIG[nic-ethtool] = "--enable-nic-ethtool,--disable-nic-ethtool,,"
-PACKAGECONFIG[sync-mac] = "--enable-sync-mac,--disable-sync-mac,,"
+PACKAGECONFIG[uboot-env] = "-Duboot-env=true,-Duboot-env=false,,${UBOOT_ENV_RDEPENDS}"
+PACKAGECONFIG[default-link-local-autoconf] = "-Ddefault-link-local-autoconf=true,-Ddefault-link-local-autoconf=false,,"
+PACKAGECONFIG[default-ipv6-accept-ra] = "-Ddefault-ipv6-accept-ra=true,-Ddefault-ipv6-accept-ra=false,,"
+PACKAGECONFIG[nic-ethtool] = "-Dnic-ethtool=true,-Dnic-ethtool=false,,"
+PACKAGECONFIG[sync-mac] = "-Dsync-mac=true,-Dsync-mac=false,nlohmann-json,"
S = "${WORKDIR}/git"
-SERVICE_FILE = "xyz.openbmc_project.Network.service"
+FILES_${PN} += "${datadir}/dbus-1/system.d"
+
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} += "${SERVICE_FILE}"
+SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Network.service"
-EXTRA_OECONF = " \
- SYSTEMD_TARGET="multi-user.target" \
-"
+EXTRA_OEMESON += "-Dtests=disabled"