summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/mrw/mrw-api-native.bb6
-rw-r--r--meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb6
2 files changed, 9 insertions, 3 deletions
diff --git a/meta-phosphor/recipes-phosphor/mrw/mrw-api-native.bb b/meta-phosphor/recipes-phosphor/mrw/mrw-api-native.bb
index b08db6930..1d277cf2b 100644
--- a/meta-phosphor/recipes-phosphor/mrw/mrw-api-native.bb
+++ b/meta-phosphor/recipes-phosphor/mrw/mrw-api-native.bb
@@ -2,9 +2,9 @@ SUMMARY = "Phosphor OpenBMC machine readable workbook API modules"
DESCRIPTION = "The API for the MRW XML generated by the Serverwiz tool"
PR = "r1"
LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=d2794c0df5b907fdace235a619d80314"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
-S = "${WORKDIR}/scripts"
+S = "${WORKDIR}/git"
inherit native
inherit perlnative
@@ -18,5 +18,5 @@ SRCREV = "${MRW_API_SRCREV}"
do_install() {
install -d ${D}${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw
- install -m 0755 Targets.pm ${D}${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw/Targets.pm
+ install -m 0755 scripts/Targets.pm ${D}${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw/Targets.pm
}
diff --git a/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb b/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
index 1a178a998..d6537f54f 100644
--- a/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
+++ b/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
@@ -15,6 +15,7 @@ PACKAGES = " \
${PN}-inventory \
${PN}-leds \
${PN}-logging \
+ ${PN}-remote-logging \
${PN}-sensors \
${PN}-software \
${PN}-host-check-mgmt \
@@ -83,7 +84,12 @@ RDEPENDS_${PN}-leds = " \
SUMMARY_${PN}-logging = "Logging applications"
RDEPENDS_${PN}-logging = " \
phosphor-logging \
+ "
+
+SUMMARY_${PN}-remote-logging = "Remote logging applications"
+RDEPENDS_${PN}-remote-logging = " \
rsyslog \
+ rsyslog-policy \
phosphor-rsyslog-config \
"