summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb')
-rwxr-xr-xmeta-phosphor/recipes-x86/chassis/x86-power-control_git.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb b/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb
index 04fd5dc63..424ad28de 100755
--- a/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb
+++ b/meta-phosphor/recipes-x86/chassis/x86-power-control_git.bb
@@ -1,8 +1,8 @@
SUMMARY = "Chassis Power Control service for Intel based platforms"
DESCRIPTION = "Chassis Power Control service for Intel based platforms"
-SRC_URI = "git://github.com/openbmc/x86-power-control.git;protocol=ssh"
-SRCREV = "48c94c59728023cdbff3bd62f203de3434af8b8a"
+SRC_URI = "git://github.com/openbmc/x86-power-control.git;protocol=https"
+SRCREV = "c46ebb493f0e0cc1ccc5525d5484465bba69551f"
PV = "1.0+git${SRCPV}"
@@ -11,7 +11,7 @@ S = "${WORKDIR}/git"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-inherit cmake systemd
+inherit meson systemd pkgconfig
inherit obmc-phosphor-dbus-service
def get_service(d):
@@ -33,4 +33,4 @@ DEPENDS += " \
sdbusplus \
phosphor-logging \
"
-FILES:${PN} += "${systemd_system_unitdir}/xyz.openbmc_project.Chassis.Control.Power@.service" \ No newline at end of file
+FILES:${PN} += "${systemd_system_unitdir}/xyz.openbmc_project.Chassis.Control.Power@.service"