summaryrefslogtreecommitdiff
path: root/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/chassis
diff options
context:
space:
mode:
Diffstat (limited to 'meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/chassis')
-rw-r--r--meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/chassis/ir38163-workaround.bb31
-rw-r--r--meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/chassis/ir38163-workaround/ir-add@.service16
-rw-r--r--meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/chassis/ir38163-workaround/ir-remove@.service13
-rw-r--r--meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/chassis/ir38163-workaround/ir38163_workaround.sh19
4 files changed, 0 insertions, 79 deletions
diff --git a/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/chassis/ir38163-workaround.bb b/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/chassis/ir38163-workaround.bb
deleted file mode 100644
index 0ac6c8ecd..000000000
--- a/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/chassis/ir38163-workaround.bb
+++ /dev/null
@@ -1,31 +0,0 @@
-SUMMARY = "centriq2400 VR sensor Re-Probe"
-DESCRIPTION = "IR38163 work on DC on state, need re-probe for centriq2400 HW design"
-PR = "r0"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit obmc-phosphor-systemd
-
-PROVIDES += 'virtual/ir38163-workaround'
-RPROVIDES_${PN} += 'virtual-ir38163-workaround'
-
-IR_REMOVE = "ir-remove@.service"
-IR_ADD = "ir-add@.service"
-INSTIR_REMOVE = "ir-remove@{0}.service"
-INSTIR_ADD = "ir-add@{0}.service"
-TGTFMT_OFF = "obmc-chassis-poweroff@{0}.target"
-TGTFMT_ON = "obmc-chassis-poweron@{0}.target"
-FMT_REMOVE = "../${IR_REMOVE}:${TGTFMT_OFF}.wants/${INSTIR_REMOVE}"
-FMT_ADD = "../${IR_ADD}:${TGTFMT_ON}.requires/${INSTIR_ADD}"
-
-SYSTEMD_SERVICE_${PN} += "${IR_REMOVE}"
-SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT_REMOVE', 'OBMC_CHASSIS_INSTANCES')}"
-SYSTEMD_SERVICE_${PN} += "${IR_ADD}"
-SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT_ADD', 'OBMC_CHASSIS_INSTANCES')}"
-
-SRC_URI += "file://ir38163_workaround.sh"
-
-do_install() {
- install -d ${D}${bindir}
- install -m 0755 ${WORKDIR}/ir38163_workaround.sh ${D}${bindir}/ir38163_workaround.sh
-}
diff --git a/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/chassis/ir38163-workaround/ir-add@.service b/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/chassis/ir38163-workaround/ir-add@.service
deleted file mode 100644
index 0b3574b2c..000000000
--- a/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/chassis/ir38163-workaround/ir-add@.service
+++ /dev/null
@@ -1,16 +0,0 @@
-[Unit]
-Description=Add IR38163 device
-Wants=obmc-power-start@%i.target
-Before=obmc-power-start@%i.target
-Conflicts=obmc-chassis-poweroff@%i.target
-ConditionPathExists=!/run/openbmc/chassis@%i-on
-
-[Service]
-ExecStart=/usr/bin/env ir38163_workaround.sh add
-SyslogIdentifier=ir38163_workaround.sh
-Type=oneshot
-RemainAfterExit=yes
-
-[Install]
-WantedBy=obmc-host-start@%i.target
-
diff --git a/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/chassis/ir38163-workaround/ir-remove@.service b/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/chassis/ir38163-workaround/ir-remove@.service
deleted file mode 100644
index 15e8d0108..000000000
--- a/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/chassis/ir38163-workaround/ir-remove@.service
+++ /dev/null
@@ -1,13 +0,0 @@
-[Unit]
-Description=Remove IR38163 device
-After=obmc-power-off@%i.target
-Conflicts=obmc-chassis-poweron@%i.target
-
-[Service]
-ExecStart=/usr/bin/env ir38163_workaround.sh rm
-SyslogIdentifier=ir38163_workaround.sh
-Type=oneshot
-RemainAfterExit=yes
-
-[Install]
-WantedBy=obmc-host-stop@%i.target
diff --git a/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/chassis/ir38163-workaround/ir38163_workaround.sh b/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/chassis/ir38163-workaround/ir38163_workaround.sh
deleted file mode 100644
index d94ea45e4..000000000
--- a/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/chassis/ir38163-workaround/ir38163_workaround.sh
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/bin/sh -e
-# For one of the IR38163 device on i2c bus 5, address 0x42
-# Because the device only work when DC-ON, so when BMC during the DC-OFF state
-# the device will probe fail, need the workaround for this HW design..
-
-if [ "$1" == "add" ]; then
- echo Add the 0x42 device on i2c bus 5....
- sleep 2
- echo 5-0042 > /sys/bus/i2c/drivers/ir38163/bind
- sleep 1
-elif [ "$1" == "rm" ]; then
- echo Remove the 0x42 device
- sleep 2
- echo 5-0042 > /sys/bus/i2c/drivers/ir38163/unbind
- sleep 1
-else
- echo "$0 <add|rm>" to set state
-fi
-