summaryrefslogtreecommitdiff
path: root/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/workbook
diff options
context:
space:
mode:
Diffstat (limited to 'meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/workbook')
-rw-r--r--meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/workbook/centriq2400-rep-config.bb38
-rw-r--r--meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/workbook/centriq2400-rep-config/Centriq2400-rep.py81
2 files changed, 0 insertions, 119 deletions
diff --git a/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/workbook/centriq2400-rep-config.bb b/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/workbook/centriq2400-rep-config.bb
deleted file mode 100644
index 220adaca4..000000000
--- a/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/workbook/centriq2400-rep-config.bb
+++ /dev/null
@@ -1,38 +0,0 @@
-SUMMARY = "Qualcomm Rep board wiring"
-DESCRIPTION = "Board wiring information for the Qualcomm Rep system."
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit allarch
-inherit setuptools
-inherit pythonnative
-
-PROVIDES += "virtual/obmc-inventory-data"
-RPROVIDES_${PN} += "virtual-obmc-inventory-data"
-
-DEPENDS += "python"
-
-S = "${WORKDIR}"
-SRC_URI += "file://Centriq2400-rep.py"
-
-python() {
- machine = d.getVar('MACHINE', True).capitalize() + '.py'
- d.setVar('_config_in_skeleton', machine)
-}
-
-do_make_setup() {
- cp ${S}/${_config_in_skeleton} \
- ${S}/obmc_system_config.py
- cat <<EOF > ${S}/setup.py
-from distutils.core import setup
-
-setup(name='${BPN}',
- version='${PR}',
- py_modules=['obmc_system_config'],
- )
-EOF
-}
-
-addtask make_setup after do_patch before do_configure
-
diff --git a/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/workbook/centriq2400-rep-config/Centriq2400-rep.py b/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/workbook/centriq2400-rep-config/Centriq2400-rep.py
deleted file mode 100644
index 903964dd7..000000000
--- a/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/workbook/centriq2400-rep-config/Centriq2400-rep.py
+++ /dev/null
@@ -1,81 +0,0 @@
-## System states
-## state can change to next state in 2 ways:
-## - a process emits a GotoSystemState signal with state name to goto
-## - objects specified in EXIT_STATE_DEPEND have started
-SYSTEM_STATES = [
- 'BASE_APPS',
- 'BMC_STARTING',
- 'BMC_READY',
- 'HOST_POWERING_ON',
- 'HOST_POWERED_ON',
- 'HOST_BOOTING',
- 'HOST_BOOTED',
- 'HOST_POWERED_OFF',
-]
-
-EXIT_STATE_DEPEND = {
- 'BASE_APPS' : {
- '/org/openbmc/sensors': 0,
- },
- 'BMC_STARTING' : {
- '/org/openbmc/control/power0' : 0,
- '/org/openbmc/control/host0' : 0,
- '/org/openbmc/control/chassis0' : 0,
- },
-}
-
-FRU_INSTANCES = {
-'<inventory_root>/system/chassis/motherboard/bmc' : { 'fru_type' : 'BMC','is_fru' : False, 'manufacturer' : 'ASPEED' },
-}
-# I believe these numbers need to match the yaml file used to create the c++ ipmi map.
-# the devices have types, but I don't believe that factors in here, I think these are
-# just unique IDs.
-ID_LOOKUP = {
- 'FRU' : {},
- # The number at the end needs to match the FRU ID.
- # https://github.com/openbmc/skeleton/blob/master/pysystemmgr/system_manager.py#L143
- # The parameter for it is of type 'y' (unsigned 8-bit integer) presumably decimal?
- 'FRU_STR' : {},
- 'SENSOR' : {},
- 'GPIO_PRESENT' : {}
-}
-
-GPIO_CONFIG = {}
-GPIO_CONFIG['POWER_BUTTON'] = { 'gpio_pin': 'D3', 'direction': 'out' }
-GPIO_CONFIG['PGOOD'] = { 'gpio_pin': 'E2', 'direction': 'in' }
-GPIO_CONFIG['BMC_READY'] = { 'gpio_pin': 'Q4', 'direction': 'out' }
-GPIO_CONFIG['HOST_SPI_SWITCH'] = { 'gpio_pin': 'C7', 'direction': 'out'}
-GPIO_CONFIG['IMC_READY'] = { 'gpio_pin': 'O3', 'direction': 'both' }
-GPIO_CONFIG['IMC_INTERRUPT'] = { 'gpio_pin': 'O4', 'direction': 'both' }
-GPIO_CONFIG['RESET_BUTTON'] = { 'gpio_pin': 'G5', 'direction': 'both' }
-GPIO_CONFIG['QDF_RAS_ERROR_0'] = { 'gpio_pin': 'D6', 'direction': 'in' }
-GPIO_CONFIG['QDF_RAS_ERROR_1'] = { 'gpio_pin': 'D7', 'direction': 'in' }
-GPIO_CONFIG['QDF_RAS_ERROR_2'] = { 'gpio_pin': 'F1', 'direction': 'in' }
-
-GPIO_CONFIGS = {
- 'power_config' : {
- 'power_good_in' : 'PGOOD',
- 'power_up' : [
-#delay in ms
- ('POWER_BUTTON', 'LOW_HIGH',1000),
- ],
- 'power_out' : [
- ('POWER_BUTTON', 'LOW_HIGH',8000),
- ],
- }}
- 'host_config' : {
- 'imc_ready' : 'IMC_READY',
- 'imc_interrupt': 'IMC_INTERRUPT',
- 'bmc_ready' : 'BMC_READY',
- 'host_spi_switch' : 'HOST_SPI_SWITCH',
- },
-}
-
-# Miscellaneous non-poll sensor with system specific properties.
-# The sensor id is the same as those defined in ID_LOOKUP['SENSOR'].
-
-MISC_SENSORS = {
-
-}
-
-# vim: tabstop=8 expandtab shiftwidth=4 softtabstop=4