summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-common/recipes-quanta/enable-tls/enable-tls.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-quanta/meta-common/recipes-quanta/enable-tls/enable-tls.bb')
-rw-r--r--meta-quanta/meta-common/recipes-quanta/enable-tls/enable-tls.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-quanta/meta-common/recipes-quanta/enable-tls/enable-tls.bb b/meta-quanta/meta-common/recipes-quanta/enable-tls/enable-tls.bb
new file mode 100644
index 000000000..fca483e11
--- /dev/null
+++ b/meta-quanta/meta-common/recipes-quanta/enable-tls/enable-tls.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Enable TLS with static CA"
+DESCRIPTION = "Add static CA and only enable TLS authentication"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://certs/authority/ \
+ file://bmcweb_persistent_data.json \
+ "
+do_install(){
+ install -d ${D}${sysconfdir}/ssl/certs/authority
+ install -m 0644 -D ${WORKDIR}/certs/authority/* \
+ ${D}${sysconfdir}/ssl/certs/authority
+
+ install -d ${D}${ROOT_HOME}
+ install -m 0640 ${WORKDIR}/bmcweb_persistent_data.json ${D}${ROOT_HOME}
+}
+
+FILES_${PN} = "${ROOT_HOME}/bmcweb_persistent_data.json \
+ ${sysconfdir}/ssl/certs/authority/* \
+ "