summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'meta-raspberrypi/recipes-bsp')
-rw-r--r--meta-raspberrypi/recipes-bsp/u-boot/u-boot-fw-utils_2019.07.bbappend2
-rw-r--r--meta-raspberrypi/recipes-bsp/u-boot/u-boot-rpi4-2019.07.inc12
-rw-r--r--meta-raspberrypi/recipes-bsp/u-boot/u-boot_2019.07.bbappend14
3 files changed, 16 insertions, 12 deletions
diff --git a/meta-raspberrypi/recipes-bsp/u-boot/u-boot-fw-utils_2019.07.bbappend b/meta-raspberrypi/recipes-bsp/u-boot/u-boot-fw-utils_2019.07.bbappend
new file mode 100644
index 000000000..3daf157d7
--- /dev/null
+++ b/meta-raspberrypi/recipes-bsp/u-boot/u-boot-fw-utils_2019.07.bbappend
@@ -0,0 +1,2 @@
+# Apply the same patches for rpi4 as u-boot recipe
+require u-boot-rpi4-${PV}.inc
diff --git a/meta-raspberrypi/recipes-bsp/u-boot/u-boot-rpi4-2019.07.inc b/meta-raspberrypi/recipes-bsp/u-boot/u-boot-rpi4-2019.07.inc
new file mode 100644
index 000000000..2ce55a2b1
--- /dev/null
+++ b/meta-raspberrypi/recipes-bsp/u-boot/u-boot-rpi4-2019.07.inc
@@ -0,0 +1,12 @@
+FILESEXTRAPATHS_prepend_raspberrypi4 := "${THISDIR}/u-boot-2019.07:"
+UBOOT_RPI4_SUPPORT_PATCHES = " \
+ file://0001-configs-rpi4-Add-defconfigs-for-rpi4-32-64.patch \
+ file://0002-ARM-bcm283x-Add-BCM283x_BASE-define.patch \
+ file://0003-arm-mach-bcm283x-Define-configs-for-RaspberryPi-4.patch \
+ file://0004-rpi-Add-entry-for-Raspberry-Pi-4-model-B.patch \
+ file://0005-arm-bcm283x-Include-definition-for-additional-emmc-c.patch \
+ file://0006-mmc-bcm2835_sdhci-Add-support-for-bcm2711-device.patch \
+ file://0007-rpi-Add-memory-map-for-bcm2838.patch \
+"
+
+SRC_URI_append_raspberrypi4 = "${UBOOT_RPI4_SUPPORT_PATCHES}"
diff --git a/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2019.07.bbappend b/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2019.07.bbappend
index 7cd8d66c3..3daf157d7 100644
--- a/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2019.07.bbappend
+++ b/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2019.07.bbappend
@@ -1,12 +1,2 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-${PV}:"
-UBOOT_RPI4_SUPPORT_PATCHES = " \
- file://0001-configs-rpi4-Add-defconfigs-for-rpi4-32-64.patch \
- file://0002-ARM-bcm283x-Add-BCM283x_BASE-define.patch \
- file://0003-arm-mach-bcm283x-Define-configs-for-RaspberryPi-4.patch \
- file://0004-rpi-Add-entry-for-Raspberry-Pi-4-model-B.patch \
- file://0005-arm-bcm283x-Include-definition-for-additional-emmc-c.patch \
- file://0006-mmc-bcm2835_sdhci-Add-support-for-bcm2711-device.patch \
- file://0007-rpi-Add-memory-map-for-bcm2838.patch \
-"
-
-SRC_URI_append_raspberrypi4 = "${UBOOT_RPI4_SUPPORT_PATCHES}"
+# Apply the same patches for rpi4 as u-boot recipe
+require u-boot-rpi4-${PV}.inc