summaryrefslogtreecommitdiff
path: root/meta-tyan/meta-common/recipes-x86/chassis/x86-power-control_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-tyan/meta-common/recipes-x86/chassis/x86-power-control_%.bbappend')
-rw-r--r--meta-tyan/meta-common/recipes-x86/chassis/x86-power-control_%.bbappend11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-tyan/meta-common/recipes-x86/chassis/x86-power-control_%.bbappend b/meta-tyan/meta-common/recipes-x86/chassis/x86-power-control_%.bbappend
new file mode 100644
index 000000000..c0fe1dd72
--- /dev/null
+++ b/meta-tyan/meta-common/recipes-x86/chassis/x86-power-control_%.bbappend
@@ -0,0 +1,11 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+SRC_URI:append = " \
+ file://power-config-host0.json \
+"
+
+RDEPENDS:${PN}:append = " bash"
+
+do_install:append() {
+ install -d ${D}${datadir}/${PN}
+ install -m 0644 ${WORKDIR}/power-config-host0.json ${D}${datadir}/${PN}
+}