summaryrefslogtreecommitdiff
path: root/meta-tyan/meta-common
diff options
context:
space:
mode:
Diffstat (limited to 'meta-tyan/meta-common')
-rw-r--r--meta-tyan/meta-common/recipes-phosphor/console/obmc-console/obmc-console.conf3
-rw-r--r--meta-tyan/meta-common/recipes-phosphor/console/obmc-console_%.bbappend2
-rw-r--r--meta-tyan/meta-common/recipes-phosphor/dummy/tyan-dummy.bb8
-rw-r--r--meta-tyan/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend1
-rw-r--r--meta-tyan/meta-common/recipes-phosphor/packagegroups/packagegroup-tyan-apps.bb39
-rw-r--r--meta-tyan/meta-common/recipes-x86/chassis/x86-power-control/power-config-host0.json69
-rw-r--r--meta-tyan/meta-common/recipes-x86/chassis/x86-power-control_%.bbappend11
7 files changed, 133 insertions, 0 deletions
diff --git a/meta-tyan/meta-common/recipes-phosphor/console/obmc-console/obmc-console.conf b/meta-tyan/meta-common/recipes-phosphor/console/obmc-console/obmc-console.conf
new file mode 100644
index 000000000..8491f5365
--- /dev/null
+++ b/meta-tyan/meta-common/recipes-phosphor/console/obmc-console/obmc-console.conf
@@ -0,0 +1,3 @@
+baud = 115200
+local-tty = ttyS3
+local-tty-baud = 115200
diff --git a/meta-tyan/meta-common/recipes-phosphor/console/obmc-console_%.bbappend b/meta-tyan/meta-common/recipes-phosphor/console/obmc-console_%.bbappend
new file mode 100644
index 000000000..18bcfe350
--- /dev/null
+++ b/meta-tyan/meta-common/recipes-phosphor/console/obmc-console_%.bbappend
@@ -0,0 +1,2 @@
+FILESEXTRAPATHS:append := "${THISDIR}/${PN}:"
+OBMC_CONSOLE_HOST_TTY = "ttyS2"
diff --git a/meta-tyan/meta-common/recipes-phosphor/dummy/tyan-dummy.bb b/meta-tyan/meta-common/recipes-phosphor/dummy/tyan-dummy.bb
new file mode 100644
index 000000000..54b93855a
--- /dev/null
+++ b/meta-tyan/meta-common/recipes-phosphor/dummy/tyan-dummy.bb
@@ -0,0 +1,8 @@
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+ALLOW_EMPTY_${PN} = "1"
+
+PROVIDES += "virtual/obmc-fan-mgmt"
+RPROVIDES:${PN} += "virtual-obmc-fan-mgmt"
+
diff --git a/meta-tyan/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend b/meta-tyan/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
new file mode 100644
index 000000000..bc70432fd
--- /dev/null
+++ b/meta-tyan/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
@@ -0,0 +1 @@
+PACKAGECONFIG:append = " dynamic-sensors"
diff --git a/meta-tyan/meta-common/recipes-phosphor/packagegroups/packagegroup-tyan-apps.bb b/meta-tyan/meta-common/recipes-phosphor/packagegroups/packagegroup-tyan-apps.bb
new file mode 100644
index 000000000..b29cca434
--- /dev/null
+++ b/meta-tyan/meta-common/recipes-phosphor/packagegroups/packagegroup-tyan-apps.bb
@@ -0,0 +1,39 @@
+SUMMARY = "OpenBMC for TYAN - Applications"
+PR = "r1"
+
+inherit packagegroup
+
+PROVIDES = "${PACKAGES}"
+PACKAGES = " \
+ ${PN}-chassis \
+ ${PN}-flash \
+ ${PN}-system \
+ "
+
+PROVIDES += "virtual/obmc-chassis-mgmt"
+PROVIDES += "virtual/obmc-flash-mgmt"
+PROVIDES += "virtual/obmc-system-mgmt"
+
+RPROVIDES:${PN}-chassis += "virtual-obmc-chassis-mgmt"
+RPROVIDES:${PN}-flash += "virtual-obmc-flash-mgmt"
+RPROVIDES:${PN}-system += "virtual-obmc-system-mgmt"
+
+SUMMARY:${PN}-chassis = "TYAN Chassis"
+RDEPENDS:${PN}-chassis = " \
+ x86-power-control \
+ "
+
+SUMMARY:${PN}-flash = "TYAN Flash"
+RDEPENDS:${PN}-flash = " \
+ phosphor-software-manager \
+ "
+
+SUMMARY:${PN}-system = "TYAN System"
+RDEPENDS:${PN}-system = " \
+ dbus-sensors \
+ phosphor-hostlogger \
+ phosphor-sel-logger \
+ ipmitool \
+ phosphor-post-code-manager \
+ phosphor-host-postd \
+ "
diff --git a/meta-tyan/meta-common/recipes-x86/chassis/x86-power-control/power-config-host0.json b/meta-tyan/meta-common/recipes-x86/chassis/x86-power-control/power-config-host0.json
new file mode 100644
index 000000000..bbeea06c6
--- /dev/null
+++ b/meta-tyan/meta-common/recipes-x86/chassis/x86-power-control/power-config-host0.json
@@ -0,0 +1,69 @@
+{
+ "gpio_configs":[
+ {
+ "Name" : "IdButton",
+ "LineName" : "id-button",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+ {
+ "Name" : "NMIButton",
+ "LineName" : "nmi-button",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+ {
+ "Name" : "NMIOut",
+ "LineName" : "nmi-control",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+ {
+ "Name" : "PostComplete",
+ "LineName" : "post-complete",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+ {
+ "Name" : "PowerButton",
+ "LineName" : "power-button",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+ {
+ "Name" : "PowerOk",
+ "LineName" : "power-chassis-good",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveHigh"
+ },
+ {
+ "Name" : "PowerOut",
+ "LineName" : "power-chassis-control",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+ {
+ "Name" : "ResetButton",
+ "LineName" : "reset-button",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ },
+ {
+ "Name" : "ResetOut",
+ "LineName" : "reset-control",
+ "Type" : "GPIO",
+ "Polarity" : "ActiveLow"
+ }
+ ],
+ "timing_configs":{
+ "PowerPulseMs": 200,
+ "ForceOffPulseMs": 15000,
+ "ResetPulseMs": 500,
+ "PowerCycleMs": 5000,
+ "SioPowerGoodWatchdogMs": 1000,
+ "PsPowerOKWatchdogMs": 8000,
+ "GracefulPowerOffS": 300,
+ "WarmResetCheckMs": 500,
+ "PowerOffSaveMs": 7000
+ }
+}
diff --git a/meta-tyan/meta-common/recipes-x86/chassis/x86-power-control_%.bbappend b/meta-tyan/meta-common/recipes-x86/chassis/x86-power-control_%.bbappend
new file mode 100644
index 000000000..c0fe1dd72
--- /dev/null
+++ b/meta-tyan/meta-common/recipes-x86/chassis/x86-power-control_%.bbappend
@@ -0,0 +1,11 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+SRC_URI:append = " \
+ file://power-config-host0.json \
+"
+
+RDEPENDS:${PN}:append = " bash"
+
+do_install:append() {
+ install -d ${D}${datadir}/${PN}
+ install -m 0644 ${WORKDIR}/power-config-host0.json ${D}${datadir}/${PN}
+}