summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-core/musl/libucontext_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-core/musl/libucontext_git.bb')
-rw-r--r--poky/meta/recipes-core/musl/libucontext_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/poky/meta/recipes-core/musl/libucontext_git.bb b/poky/meta/recipes-core/musl/libucontext_git.bb
index ec988f192..734ad9c95 100644
--- a/poky/meta/recipes-core/musl/libucontext_git.bb
+++ b/poky/meta/recipes-core/musl/libucontext_git.bb
@@ -43,6 +43,7 @@ def map_kernel_arch(a, d):
elif re.match('p(pc|owerpc)', a): return 'ppc'
elif re.match('p(pc64|owerpc64)', a): return 'ppc64'
elif re.match('riscv64$', a): return 'riscv64'
+ elif re.match('riscv32$', a): return 'riscv32'
else:
if not d.getVar("TARGET_OS").startswith("linux"):
return a