summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-devtools/ccache/ccache_4.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-devtools/ccache/ccache_4.2.1.bb')
-rw-r--r--poky/meta/recipes-devtools/ccache/ccache_4.2.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/poky/meta/recipes-devtools/ccache/ccache_4.2.1.bb b/poky/meta/recipes-devtools/ccache/ccache_4.2.1.bb
new file mode 100644
index 000000000..8dd5893d6
--- /dev/null
+++ b/poky/meta/recipes-devtools/ccache/ccache_4.2.1.bb
@@ -0,0 +1,27 @@
+SUMMARY = "a fast C/C++ compiler cache"
+DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \
+by caching the result of previous compilations and detecting when the \
+same compilation is being done again. Supported languages are C, C\+\+, \
+Objective-C and Objective-C++."
+HOMEPAGE = "http://ccache.samba.org"
+SECTION = "devel"
+
+LICENSE = "GPLv3+"
+LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=698a26b57e513d678e1e7727bf56395b"
+
+DEPENDS = "zstd"
+
+SRC_URI = "https://github.com/ccache/ccache/releases/download/v${PV}/${BP}.tar.gz \
+ file://0001-doc-allow-disabling-docs-man-page-generation.patch \
+ "
+SRC_URI[sha256sum] = "320d2b17d2f76393e5d4bb28c8dee5ca783248e9cd23dff0654694d60f8a4b62"
+
+UPSTREAM_CHECK_URI = "https://github.com/ccache/ccache/releases/"
+
+inherit cmake
+
+PATCHTOOL = "patch"
+
+BBCLASSEXTEND = "native nativesdk"
+
+PACKAGECONFIG[docs] = "-DBUILD_DOCS=ON,-DBUILD_DOCS=OFF,asciidoc"