summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-devtools/help2man/help2man-native_1.47.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-devtools/help2man/help2man-native_1.47.15.bb')
-rw-r--r--poky/meta/recipes-devtools/help2man/help2man-native_1.47.15.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/poky/meta/recipes-devtools/help2man/help2man-native_1.47.15.bb b/poky/meta/recipes-devtools/help2man/help2man-native_1.47.15.bb
new file mode 100644
index 000000000..4f80a2bdb
--- /dev/null
+++ b/poky/meta/recipes-devtools/help2man/help2man-native_1.47.15.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Program for creating simple man pages"
+SECTION = "devel"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
+DEPENDS = "autoconf-native automake-native"
+
+SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.xz"
+SRC_URI[sha256sum] = "c25a35b30eceb315361484b0ff1f81c924e8ee5c8881576f1ee762f001dbcd1c"
+
+inherit autotools native
+
+EXTRA_OECONF = "--disable-nls"
+
+# We don't want to reconfigure things as it would require 'perlnative' to be
+# used.
+do_configure() {
+ oe_runconf
+}
+
+do_install_append () {
+ # Make sure we use /usr/bin/env perl
+ sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man
+}