summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-devtools/libmodulemd/libmodulemd_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-devtools/libmodulemd/libmodulemd_git.bb')
-rw-r--r--poky/meta/recipes-devtools/libmodulemd/libmodulemd_git.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/poky/meta/recipes-devtools/libmodulemd/libmodulemd_git.bb b/poky/meta/recipes-devtools/libmodulemd/libmodulemd_git.bb
index d440e60ee..fda01b8ad 100644
--- a/poky/meta/recipes-devtools/libmodulemd/libmodulemd_git.bb
+++ b/poky/meta/recipes-devtools/libmodulemd/libmodulemd_git.bb
@@ -4,17 +4,16 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=25a3927bff3ee4f5b21bcb0ed3fcd6bb"
SRC_URI = "git://github.com/fedora-modularity/libmodulemd;protocol=https \
file://0001-modulemd-generate-the-manpage-only-if-the-feature-is.patch \
- file://0002-meson.build-do-not-install-python-gi-bindings.patch \
"
-PV = "2.9.2"
-SRCREV = "780750eab8a0587b20d033f335301f16d00ab9c9"
+PV = "2.9.4"
+SRCREV = "c7254db07b21495fc9bd247c5b17ee20149c05e3"
S = "${WORKDIR}/git"
-inherit meson gobject-introspection
+inherit meson gobject-introspection python3-dir
-EXTRA_OEMESON = "-Ddeveloper_build=false -Dwith_docs=false -Drpmio=disabled -Dlibmagic=disabled -Dwith_manpages=disabled"
+EXTRA_OEMESON = "-Ddeveloper_build=false -Dwith_docs=false -Drpmio=disabled -Dlibmagic=disabled -Dwith_manpages=disabled -Dgobject_overrides_dir_py3=${PYTHON_SITEPACKAGES_DIR}/gi/overrides"
DEPENDS += "glib-2.0 libyaml glib-2.0-native python3"
@@ -23,3 +22,5 @@ BBCLASSEXTEND = "native nativesdk"
GIR_MESON_OPTION = 'skip_introspection'
GIR_MESON_ENABLE_FLAG = 'false'
GIR_MESON_DISABLE_FLAG = 'true'
+
+FILES_${PN} += "${libdir}/${PYTHON_DIR}/*"