summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-extended/stress-ng/stress-ng_0.11.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-extended/stress-ng/stress-ng_0.11.12.bb')
-rw-r--r--poky/meta/recipes-extended/stress-ng/stress-ng_0.11.12.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/poky/meta/recipes-extended/stress-ng/stress-ng_0.11.12.bb b/poky/meta/recipes-extended/stress-ng/stress-ng_0.11.12.bb
new file mode 100644
index 000000000..45f4bb41a
--- /dev/null
+++ b/poky/meta/recipes-extended/stress-ng/stress-ng_0.11.12.bb
@@ -0,0 +1,26 @@
+SUMMARY = "System load testing utility"
+DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \
+imposes a configurable amount of CPU, memory, I/O, and disk stress on the system."
+HOMEPAGE = "https://kernel.ubuntu.com/~cking/stress-ng/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "https://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \
+ file://0001-Do-not-preserve-ownership-when-installing-example-jo.patch \
+ "
+SRC_URI[sha256sum] = "0ccf437ca1876a3e8a55986c6481697045203a17f5994cb2f5096cd461d18031"
+
+DEPENDS = "coreutils-native"
+
+PROVIDES = "stress"
+RPROVIDES_${PN} = "stress"
+RREPLACES_${PN} = "stress"
+RCONFLICTS_${PN} = "stress"
+
+inherit bash-completion
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}
+
+COMPATIBLE_HOST_libc-musl = 'null'