summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.31.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.31.bb')
-rw-r--r--poky/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.31.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/poky/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.31.bb b/poky/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.31.bb
new file mode 100644
index 000000000..ad150544e
--- /dev/null
+++ b/poky/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.31.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Keyboard configuration database for X Window"
+
+DESCRIPTION = "The non-arch keyboard configuration database for X \
+Window. The goal is to provide the consistent, well-structured, \
+frequently released open source of X keyboard configuration data for X \
+Window System implementations. The project is targeted to XKB-based \
+systems."
+
+HOMEPAGE = "http://freedesktop.org/wiki/Software/XKeyboardConfig"
+BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=xkeyboard-config"
+
+LICENSE = "MIT & MIT-style"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0e7f21ca7db975c63467d2e7624a12f9"
+
+SRC_URI = "${XORG_MIRROR}/individual/data/xkeyboard-config/${BPN}-${PV}.tar.bz2"
+SRC_URI[sha256sum] = "da44181f2c8828789c720decf7d13acb3c3950e2a040af5132f50f04bb6aada3"
+
+SECTION = "x11/libs"
+DEPENDS = "util-macros libxslt-native"
+
+EXTRA_OECONF = "--with-xkb-rules-symlink=xorg --disable-runtime-deps"
+
+FILES_${PN} += "${datadir}/X11/xkb"
+
+inherit autotools pkgconfig gettext python3native
+
+do_install_append () {
+ install -d ${D}${datadir}/X11/xkb/compiled
+ cd ${D}${datadir}/X11/xkb/rules && ln -sf base xorg
+}