summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-support/enchant/enchant2_2.2.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-support/enchant/enchant2_2.2.13.bb')
-rw-r--r--poky/meta/recipes-support/enchant/enchant2_2.2.13.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/poky/meta/recipes-support/enchant/enchant2_2.2.13.bb b/poky/meta/recipes-support/enchant/enchant2_2.2.13.bb
new file mode 100644
index 000000000..3b890e733
--- /dev/null
+++ b/poky/meta/recipes-support/enchant/enchant2_2.2.13.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Enchant Spell checker API Library"
+SECTION = "libs"
+HOMEPAGE = "https://abiword.github.io/enchant/"
+LICENSE = "LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
+
+DEPENDS = "glib-2.0"
+
+inherit autotools pkgconfig
+
+SRC_URI = "https://github.com/AbiWord/enchant/releases/download/v${PV}/enchant-${PV}.tar.gz"
+SRC_URI[sha256sum] = "eab9f90d79039133660029616e2a684644bd524be5dc43340d4cfc3fb3c68a20"
+
+UPSTREAM_CHECK_URI = "https://github.com/AbiWord/enchant/releases"
+
+S = "${WORKDIR}/enchant-${PV}"
+
+EXTRA_OEMAKE = "pkgdatadir=${datadir}/enchant-2"
+
+PACKAGECONFIG ??= "aspell"
+PACKAGECONFIG[aspell] = "--with-aspell,--without-aspell,aspell,aspell"
+PACKAGECONFIG[hunspell] = "--with-hunspell,--without-hunspell,hunspell,hunspell"
+
+FILES_${PN} += " \
+ ${datadir}/enchant-2 \
+ ${libdir}/enchant-2 \
+"
+FILES_${PN}-staticdev += "${libdir}/enchant-2/*.a"