summaryrefslogtreecommitdiff
path: root/special-mode-mgr/CMakeLists.txt
diff options
context:
space:
mode:
authorRichard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com>2020-02-05 18:26:53 +0300
committerThomaiyar, Richard Marian <richard.marian.thomaiyar@intel.com>2020-02-08 05:12:38 +0300
commitdd00e1aa35fce669ad6665904dc096f1f792a96b (patch)
tree8482dbdc9403a82c8dc6a845658c6d093033c78d /special-mode-mgr/CMakeLists.txt
parentfdb1caccf85564a28b8a11b6d9c1daa70886eaca (diff)
downloadprovingground-dd00e1aa35fce669ad6665904dc096f1f792a96b.tar.xz
[Mfg-mode]: Configure root user with null passwd
Configure special user with null password when entering manufacturing mode and special user password is in disabled state. Note: This feature is under VALIDATION_UNSECURE flag, and hence will be available for reference only image. Tested: 1. Built the image without debug-tweaks and flashed the same 2. Confirmed that root user is not enabled during regular boot 3. Pressed power button for 15 seconds during AC Cycle, and entered manufacturing mode 4. Able to login to root user with no password and updated the password to new one, due to enforcement 5. Verified upon rebooting, the newly configured password can be used to login to the serial console. 6. Entered Manufacturing mode again, to make sure root user password is not set to null again as it is already configured. Change-Id: I6aab8713a7c4d7d75b63b1b58ee063b09d9db990 Signed-off-by: Richard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com>
Diffstat (limited to 'special-mode-mgr/CMakeLists.txt')
-rw-r--r--special-mode-mgr/CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/special-mode-mgr/CMakeLists.txt b/special-mode-mgr/CMakeLists.txt
index 6fe7f86..fa69da8 100644
--- a/special-mode-mgr/CMakeLists.txt
+++ b/special-mode-mgr/CMakeLists.txt
@@ -1,6 +1,5 @@
cmake_minimum_required(VERSION 3.5 FATAL_ERROR)
project(specialmodemgr CXX)
-set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake ${CMAKE_MODULE_PATH})
set(CMAKE_CXX_STANDARD 17)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fno-rtti")
@@ -39,15 +38,12 @@ link_directories(${DBUSINTERFACE_LIBRARY_DIRS})
find_package(PkgConfig REQUIRED)
pkg_check_modules(LOGGING phosphor-logging REQUIRED)
-find_package(PAM REQUIRED)
-
add_executable(${PROJECT_NAME} ${SRC_FILES})
target_link_libraries(${PROJECT_NAME} systemd)
target_link_libraries(${PROJECT_NAME} ${SDBUSPLUSPLUS_LIBRARIES})
target_link_libraries(${PROJECT_NAME} ${DBUSINTERFACE_LIBRARIES})
target_link_libraries(${PROJECT_NAME} ${Boost_LIBRARIES})
target_link_libraries(${PROJECT_NAME} phosphor_logging)
-target_link_libraries(${PROJECT_NAME} pam)
link_directories(${EXTERNAL_INSTALL_LOCATION}/lib)