summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2019-04-09 17:15:26 +0300
committerEd Tanous <ed.tanous@intel.com>2019-04-24 18:35:14 +0300
commitb97b9c36007f21628159905f95faff7a1baa5a54 (patch)
tree483349ade29b60c53a151a86d0ee2249b2c35986 /CMakeLists.txt
parent69664cf07c2d97786b9ddb0a6709d6abab3e90ff (diff)
downloadbmcweb-b97b9c36007f21628159905f95faff7a1baa5a54.tar.xz
CMakeLists.txt: Remove BOOST_ASIO_NO_DEPRECATED
Comment out the BOOST_ASIO_NO_DEPRECATED flag until Yocto moves to Boost 1.70 (currently at 1.69), since it breaks boost/process.hpp which is used for the Virtual Media enpoint. Reference: - https://github.com/boostorg/process/issues/29 - https://github.com/boostorg/process/pull/67 Tested: Verified that the virtual media commit that includes boost/process.hpp compiles and the interface still works as expected. Change-Id: Iffc53c260a44947a0891822ec00a1562849e7ae2 Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cf20743871..d2a8b6c6e3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -128,7 +128,8 @@ add_definitions (-DBOOST_ASIO_DISABLE_THREADS)
add_definitions (-DBOOST_BEAST_USE_STD_STRING_VIEW)
add_definitions (-DBOOST_ERROR_CODE_HEADER_ONLY)
add_definitions (-DBOOST_SYSTEM_NO_DEPRECATED)
-add_definitions (-DBOOST_ASIO_NO_DEPRECATED)
+# Uncomment once Yocto moves to boost 1.70
+# add_definitions (-DBOOST_ASIO_NO_DEPRECATED)
add_definitions (-DBOOST_ALL_NO_LIB)
add_definitions (-DBOOST_NO_RTTI)
add_definitions (-DBOOST_NO_TYPEID)