summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorraviteja-b <raviteja28031990@gmail.com>2020-02-03 20:53:32 +0300
committerRavi Teja <raviteja28031990@gmail.com>2020-05-08 11:38:31 +0300
commitc9bb6861cd1bac2e1849b09176564f01c185207c (patch)
treece0f1c59130d745294648b1a1c0b49c768d89c9f /CMakeLists.txt
parent8a3bb71ebcdf14dafd5967192f73bf2416e8bb6e (diff)
downloadbmcweb-c9bb6861cd1bac2e1849b09176564f01c185207c.tar.xz
Redfish: Log service implementation for system dump
Dump is the debug data collected at any point of time from the system and is stored in a file Currently, Redfish doesn't have schema for operations on debug data(dump). This commit implements logService for system dump. we have a DMTF proposal to extend existing LogService schema for this purpose but its still work in progress, so moved to oem schema. below commit has changes to move properties to OEM https://gerrit.openbmc-project.xyz/c/openbmc/bmcweb/+/30352 Tested By: GET https://${IP}/redfish/v1/Systems/system/LogServices/SystemDump DELETE https://${IP}/redfish/v1/Systems/system/LogServices/SystemDump/Entries/<id> Redfish validator passed. (above mentioned commit required to pass validator). Change-Id: I4a4a4083be4556bc46a4335d31ce56f834bd4f5a Signed-off-by: Ravi Teja <raviteja28031990@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index be9a3742ce..547fef086d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -71,6 +71,12 @@ option (
OFF
)
option (
+ BMCWEB_ENABLE_REDFISH_SYSTEMDUMP_LOG
+ "Enable System dump log service transactions through Redfish. Paths are under
+ '/redfish/v1/Systems/system/LogServices/SystemDump'."
+ OFF
+)
+option (
BMCWEB_ENABLE_REDFISH_DBUS_LOG_ENTRIES
"Enable DBUS log service transactions through Redfish. Paths are under
'/redfish/v1/Systems/system/LogServices/EventLog/Entries'."
@@ -407,6 +413,8 @@ target_compile_definitions (
-DBMCWEB_ENABLE_REDFISH_RAW_PECI>
$<$<BOOL:${BMCWEB_ENABLE_REDFISH_CPU_LOG}>:
-DBMCWEB_ENABLE_REDFISH_CPU_LOG>
+ $<$<BOOL:${BMCWEB_ENABLE_REDFISH_SYSTEMDUMP_LOG}>:
+ -DBMCWEB_ENABLE_REDFISH_SYSTEMDUMP_LOG>
$<$<BOOL:${BMCWEB_ENABLE_REDFISH_BMC_JOURNAL}>:
-DBMCWEB_ENABLE_REDFISH_BMC_JOURNAL>
$<$<BOOL:${BMCWEB_ENABLE_REDFISH_DBUS_LOG_ENTRIES}>: