summaryrefslogtreecommitdiff
path: root/config/meson.build
diff options
context:
space:
mode:
authorEd Tanous <ed@tanous.net>2024-05-16 19:38:31 +0300
committerEd Tanous <ed@tanous.net>2024-05-21 01:42:28 +0300
commit253f11b84347de6bff7c6b624bef270fefae5f5a (patch)
tree71f8a40411f3a7482c689ea6448bc24956fc17cb /config/meson.build
parentfe907df460896297eb8b1fde00a18dd7cccab109 (diff)
downloadbmcweb-253f11b84347de6bff7c6b624bef270fefae5f5a.tar.xz
Allow configuring "bmc" and "system"
In the early days of bmcweb, we made two pretty critical assumptions; First, is that a given platform would only have a single BMC instance (represented as "bmc") and a single host instance (represented as "system"). Second we assumed that, given that Redfish suggests against hardcoding URIs in client implementation and leaves them freeform, clients would code to the standard. Our own webui-vue hardcodes Redfish URIs [1], and the documentation is littered with examples of hardcoded curl examples of hardcoding these URIs. That bug was filed in 2020, and the issue has only gotten worse over time. This patchset is an attempt to give a target that we can start solving these issues, without trying to boil the ocean and fix all clients in parallel. This commit adds the meson options redfish-manager-uri-name and redfish-system-uri-name These are used to control the "name" that bmcweb places in the fixed locations in the ManagerCollection and ComputerSystemCollection schemas. Note, managers is added, but is not currently testable. It will be iterated on over time. Tested: Changed the URL options to "edsbmc" and "edssystem" in meson options. Redfish service validator passes. URLs appear changed when walking the tree. [1] https://github.com/openbmc/webui-vue/issues/43 Change-Id: I4b44685067051512bd065da8c2e3db68ae5ce23a Signed-off-by: Ed Tanous <ed@tanous.net>
Diffstat (limited to 'config/meson.build')
-rw-r--r--config/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/config/meson.build b/config/meson.build
index 887c48d495..b500dee4dd 100644
--- a/config/meson.build
+++ b/config/meson.build
@@ -42,6 +42,8 @@ feature_options = [
string_options = [
'dns-resolver',
'mutual-tls-common-name-parsing',
+ 'redfish-manager-uri-name',
+ 'redfish-system-uri-name',
]
int_options = [