summaryrefslogtreecommitdiff
path: root/config/meson.build
diff options
context:
space:
mode:
authorEd Tanous <ed@tanous.net>2022-12-29 03:22:54 +0300
committerEd Tanous <ed@tanous.net>2023-06-21 22:31:32 +0300
commit7f3e84a151e106d9227d08358e9ee3fd225b34c4 (patch)
tree9ad5f77c62f73618e0dde7a27c658fa518118a7b /config/meson.build
parent8a7c4b475469c8811dffe265992b903060aad65f (diff)
downloadbmcweb-7f3e84a151e106d9227d08358e9ee3fd225b34c4.tar.xz
Add an option flag for multi-computersystem
A number of discussions have occurred, and it's clear that multi-computer system is not a transition that can be done in a single series of commits, and needs to be done incrementally over time. This commit adds the initial option for multi-computer system support, with an option flag that can be enabled when the new behavior is desired. This is to prevent needing a long-lived fork. This option operatates such that if enabled, all ComputerSystem route options will now return 404. This is to allow the redfish service validator to pass, and to be used for incremental development. As the routes are moved over, they will be enabled, and service validator re-run. Per the description in the meson options, this option flag, and all code beneath of it will be removed on 9/1/23. The expectation is that by this date, given the appropriate level of effort in implementation, there will be no code remaining under that option flag. After this date, code beneath this option flag will be removed. Tested: No functional changes without option. With option enabled, /redfish/v1/Systems produces no entries. Spot check of various routes returns 404. Redfish service validator passes. Change-Id: I3b58642cb76d61df668076c2e0f1e7bed110ae25 Signed-off-by: Ed Tanous <ed@tanous.net>
Diffstat (limited to 'config/meson.build')
-rw-r--r--config/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/config/meson.build b/config/meson.build
index 8e2127ef97..11ef95c6e5 100644
--- a/config/meson.build
+++ b/config/meson.build
@@ -16,6 +16,8 @@ enable_health_populate = get_option('redfish-health-populate')
conf_data.set10('BMCWEB_ENABLE_HEALTH_POPULATE', enable_health_populate.enabled())
enable_proc_mem_status = get_option('redfish-enable-proccessor-memory-status')
conf_data.set10('BMCWEB_ENABLE_PROC_MEM_STATUS', enable_proc_mem_status.enabled())
+enable_multi_host = get_option('experimental-redfish-multi-computer-system')
+conf_data.set10('BMCWEB_ENABLE_MULTI_HOST', enable_multi_host.enabled())
# Logging level
loglvlopt = get_option('bmcweb-logging')