summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2022-03-13 04:40:04 +0300
committerEd Tanous <ed@tanous.net>2022-03-17 04:52:52 +0300
commit9e710e7f988dee6d794c8f0a13e83b9b47a764db (patch)
tree0e9967df9aa187e7fa443093079936a40926ce33 /meson.build
parent6fe69b6a82d16072bd7be123600049b98ffcf132 (diff)
downloadbmcweb-9e710e7f988dee6d794c8f0a13e83b9b47a764db.tar.xz
Disable boost exceptions
There should be no case where we're throwing an exception through an asio descriptor or through the io_context, so having these options enabled don't do us much good. Tested: Code compiles, removes almost 7kB from the bmcweb binary size. Signed-off-by: Ed Tanous <edtanous@google.com> Change-Id: I91df03fd0dcb942bdfaa420ad8c0c1f8b0f634cc
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index f6fb323933..8e6e83a068 100644
--- a/meson.build
+++ b/meson.build
@@ -232,7 +232,8 @@ cxx.get_supported_arguments([
'-DBOOST_ASIO_SEPARATE_COMPILATION',
'-DBOOST_BEAST_SEPARATE_COMPILATION',
'-DBOOST_BEAST_USE_STD_STRING_VIEW',
- '-DJSON_NOEXCEPTION'
+ '-DBOOST_EXCEPTION_DISABLE',
+ '-DJSON_NOEXCEPTION',
]),
language : 'cpp')