summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ea033d7..b188908 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -98,6 +98,7 @@ set(CONVERTER_DIR src/converter)
set(LOGGER_DIR src/logger)
set(CHECKER_DIR src/checker)
set(GENERAL_DIR src/general)
+set(THREAD_DIR src/thread)
set(SRC_FILES
${SRC_DIR}/main.cpp
@@ -107,8 +108,6 @@ set(SRC_FILES
${MESSAGE_DIR}/sender.hpp
${MESSAGE_DIR}/sender.cpp
- ${MESSAGE_DIR}/thread_safe_queue.hpp
- ${MESSAGE_DIR}/thread_safe_queue.cpp
${MESSAGE_DIR}/builder/date.hpp
${MESSAGE_DIR}/builder/date.cpp
@@ -191,6 +190,9 @@ set(SRC_FILES
${GENERAL_DIR}/struct.hpp
${GENERAL_DIR}/idecorator.hpp
+
+ ${THREAD_DIR}/queue.hpp
+ ${THREAD_DIR}/queue.cpp
)
if( ${ADD_PHOSPHOR_LOGGING} STREQUAL "ON")