summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 10 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cba5aa3..7351684 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -97,6 +97,7 @@ set(MANAGER_BUILDER_DIR src/management/builder)
set(CONVERTER_DIR src/converter)
set(LOGGER_DIR src/logger)
set(CHECKER_DIR src/checker)
+set(GENERAL_DIR src/general)
set(SRC_FILES
${SRC_DIR}/main.cpp
@@ -120,13 +121,11 @@ set(SRC_FILES
${MESSAGE_DIR}/builder/from.hpp
${MESSAGE_DIR}/builder/from.cpp
${MESSAGE_DIR}/builder/types/imessage_builder.hpp
- ${MESSAGE_DIR}/builder/types/idecorator.hpp
${MANAGEMENT_DIR}/mail.hpp
${MANAGEMENT_DIR}/mail.cpp
${MANAGEMENT_DIR}/settings.hpp
${MANAGEMENT_DIR}/settings.cpp
- ${MANAGEMENT_DIR}/general.hpp
${FILE_DIR}/mail/file_decorator.hpp
${FILE_DIR}/mail/file_decorator.cpp
@@ -146,6 +145,12 @@ set(SRC_FILES
${FILE_DIR}/settings/checker_decorator.cpp
${FILE_DIR}/settings/types/ifile_manipulator.hpp
+ ${FILE_DIR}/errors/registrator.hpp
+ ${FILE_DIR}/errors/registrator.cpp
+ ${FILE_DIR}/errors/not_create.hpp
+ ${FILE_DIR}/errors/not_create.cpp
+ ${FILE_DIR}/errors/types/ierror.hpp
+
${CONVERTER_DIR}/struct_to_file.hpp
${CONVERTER_DIR}/struct_to_file.cpp
${CONVERTER_DIR}/file_to_struct.hpp
@@ -181,6 +186,9 @@ set(SRC_FILES
${CHECKER_DIR}/errors/types/imails_error.hpp
${CHECKER_DIR}/errors/types/isettings_error.hpp
+
+ ${GENERAL_DIR}/struct.hpp
+ ${GENERAL_DIR}/idecorator.hpp
)
if( ${ADD_PHOSPHOR_LOGGING} STREQUAL "ON")