summaryrefslogtreecommitdiff
path: root/import-layers/meta-openembedded/meta-oe/recipes-support
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-12-04 07:42:40 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2017-12-14 22:39:07 +0300
commit7f28bc5ce604549f6a1ef536e8d7eafe0d779a79 (patch)
treec68de3b8625b35a33d2d05f186633019154ae52b /import-layers/meta-openembedded/meta-oe/recipes-support
parentd5c08fd2c1008804ee8631d9dc013649b24576e5 (diff)
downloadopenbmc-7f28bc5ce604549f6a1ef536e8d7eafe0d779a79.tar.xz
Squashed 'import-layers/meta-openembedded/' changes from df3537259..b40116cf4
Yocto 2.2.2 (Morty) Change-Id: I3998555f14538d8306be995bcfb366173e04e975 git-subtree-dir: import-layers/meta-openembedded git-subtree-split: b40116cf457b88a2db14b86fda9627fb34d56ae6 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'import-layers/meta-openembedded/meta-oe/recipes-support')
-rw-r--r--import-layers/meta-openembedded/meta-oe/recipes-support/devmem2/devmem2.bb12
-rw-r--r--import-layers/meta-openembedded/meta-oe/recipes-support/gflags/gflags_2.1.2.bb7
-rw-r--r--import-layers/meta-openembedded/meta-oe/recipes-support/gradm/gradm/0001-Makefile-Append-instead-of-overriding-LDFLAGS.patch26
-rw-r--r--import-layers/meta-openembedded/meta-oe/recipes-support/gradm/gradm_3.1.bb4
-rw-r--r--import-layers/meta-openembedded/meta-oe/recipes-support/hwdata/hwdata_git.bb (renamed from import-layers/meta-openembedded/meta-oe/recipes-support/hwdata/hwdata_0.291.bb)10
-rw-r--r--import-layers/meta-openembedded/meta-oe/recipes-support/imagemagick/imagemagick_7.0.2.bb46
-rw-r--r--import-layers/meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils/0001-Makefiles-Respect-environment-variables-and-add-LDFL.patch61
-rw-r--r--import-layers/meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb4
-rw-r--r--import-layers/meta-openembedded/meta-oe/recipes-support/lm_sensors/lmsensors_3.4.0.bb8
-rw-r--r--import-layers/meta-openembedded/meta-oe/recipes-support/mailcap/mailcap_2.1.46.bb10
-rw-r--r--import-layers/meta-openembedded/meta-oe/recipes-support/picocom/picocom_1.7.bb3
-rw-r--r--import-layers/meta-openembedded/meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb2
-rw-r--r--import-layers/meta-openembedded/meta-oe/recipes-support/procmail/procmail_3.22.bb4
-rw-r--r--import-layers/meta-openembedded/meta-oe/recipes-support/zile/zile_2.4.11.bb5
14 files changed, 154 insertions, 48 deletions
diff --git a/import-layers/meta-openembedded/meta-oe/recipes-support/devmem2/devmem2.bb b/import-layers/meta-openembedded/meta-oe/recipes-support/devmem2/devmem2.bb
index e48cc9210b..c86eb2e4bb 100644
--- a/import-layers/meta-openembedded/meta-oe/recipes-support/devmem2/devmem2.bb
+++ b/import-layers/meta-openembedded/meta-oe/recipes-support/devmem2/devmem2.bb
@@ -1,14 +1,18 @@
SUMMARY = "Simple program to read/write from/to any location in memory"
LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://devmem2.c;endline=28;md5=dd68f2b0a5184b3db3dc25c99e0bd0cd"
+LIC_FILES_CHKSUM = "file://devmem2.c;endline=38;md5=a9eb9f3890384519f435aedf986297cf"
PR = "r7"
-SRC_URI = "http://www.lartmaker.nl/lartware/port/devmem2.c \
+SRC_URI = "http://www.free-electrons.com/pub/mirror/devmem2.c;downloadfilename=devmem2-new.c \
file://devmem2-fixups-2.patch;apply=yes;striplevel=0"
S = "${WORKDIR}"
CFLAGS += "-DFORCE_STRICT_ALIGNMENT"
+python do_unpack_append() {
+ os.rename("devmem2-new.c", "devmem2.c")
+}
+
do_compile() {
${CC} -o devmem2 devmem2.c ${CFLAGS} ${LDFLAGS}
}
@@ -18,5 +22,5 @@ do_install() {
install devmem2 ${D}${bindir}
}
-SRC_URI[md5sum] = "be12c0132a1ae118cbf5e79d98427c1d"
-SRC_URI[sha256sum] = "ec382c90af3ef2f49695ff14a4d6521e58ac482c4e29d6c9ebca8768f699c191"
+SRC_URI[md5sum] = "e23f236e94be4c429aa1ceac0f01544b"
+SRC_URI[sha256sum] = "3b15515693bae1ebd14d914e46d388edfec2175829ea1576a7a0c8606ebbe639"
diff --git a/import-layers/meta-openembedded/meta-oe/recipes-support/gflags/gflags_2.1.2.bb b/import-layers/meta-openembedded/meta-oe/recipes-support/gflags/gflags_2.1.2.bb
index b5e0597989..da82599c7f 100644
--- a/import-layers/meta-openembedded/meta-oe/recipes-support/gflags/gflags_2.1.2.bb
+++ b/import-layers/meta-openembedded/meta-oe/recipes-support/gflags/gflags_2.1.2.bb
@@ -5,9 +5,10 @@ HOMEPAGE = "https://github.com/gflags/gflags"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://COPYING.txt;md5=c80d1a3b623f72bb85a4c75b556551df"
-SRC_URI = "git://github.com/gflags/gflags.git;branch=release"
-SRCREV = "1a02f2851ee3d48d32d2c8f4d8f390a0bc25565c"
-S = "${WORKDIR}/git/"
+SRC_URI = "https://github.com/gflags/gflags/archive/v${PV}.tar.gz"
+SRC_URI[md5sum] = "ac432de923f9de1e9780b5254884599f"
+SRC_URI[sha256sum] = "d8331bd0f7367c8afd5fcb5f5e85e96868a00fd24b7276fa5fcee1e5575c2662"
+S = "${WORKDIR}/${PN}-${PV}/"
FILES_${PN}-dev += "${libdir}/cmake"
diff --git a/import-layers/meta-openembedded/meta-oe/recipes-support/gradm/gradm/0001-Makefile-Append-instead-of-overriding-LDFLAGS.patch b/import-layers/meta-openembedded/meta-oe/recipes-support/gradm/gradm/0001-Makefile-Append-instead-of-overriding-LDFLAGS.patch
new file mode 100644
index 0000000000..09a60127a4
--- /dev/null
+++ b/import-layers/meta-openembedded/meta-oe/recipes-support/gradm/gradm/0001-Makefile-Append-instead-of-overriding-LDFLAGS.patch
@@ -0,0 +1,26 @@
+From d67e93ada37d7237983fd10894c18b92f4243d50 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 18 Mar 2017 08:51:45 -0700
+Subject: [PATCH] Makefile: Append instead of overriding LDFLAGS
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 28557ff..deed94c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -29,7 +29,7 @@ OPT_FLAGS := -O2
+ # for older versions of grsecurity, comment the above line and uncomment the below:
+ #OPT_FLAGS := $(shell if [ "`uname -m`" != "sparc64" ] && [ "`uname -m`" != "x86_64" ]; then echo "-O2" ; else echo "-O2 -m64" ; fi)
+ CFLAGS := $(OPT_FLAGS) -fPIE -Wcast-qual -DGRSEC_DIR=\"$(GRSEC_DIR)\" -D_LARGEFILE64_SOURCE
+-LDFLAGS= -pie
++LDFLAGS+= -pie
+ INSTALL = /usr/bin/install -c
+
+ # FHS
+--
+2.12.0
+
diff --git a/import-layers/meta-openembedded/meta-oe/recipes-support/gradm/gradm_3.1.bb b/import-layers/meta-openembedded/meta-oe/recipes-support/gradm/gradm_3.1.bb
index 252b19de2d..1a4261a9ea 100644
--- a/import-layers/meta-openembedded/meta-oe/recipes-support/gradm/gradm_3.1.bb
+++ b/import-layers/meta-openembedded/meta-oe/recipes-support/gradm/gradm_3.1.bb
@@ -12,7 +12,9 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=4641e94ec96f98fabc56ff9cc48be14b"
DEPENDS = "flex-native bison-native ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
SRC_URI = "http://grsecurity.net/stable/${BP}-201507191652.tar.gz \
- file://0001-Makefile-remove-strip.patch"
+ file://0001-Makefile-remove-strip.patch \
+ file://0001-Makefile-Append-instead-of-overriding-LDFLAGS.patch \
+ "
SRC_URI[md5sum] = "ecec72d3a9b6d84c00eda97957b707b6"
SRC_URI[sha256sum] = "2f14c357bf0459e502a4e108b76c3f6240aa484762d07bb1687796b9b9297a50"
diff --git a/import-layers/meta-openembedded/meta-oe/recipes-support/hwdata/hwdata_0.291.bb b/import-layers/meta-openembedded/meta-oe/recipes-support/hwdata/hwdata_git.bb
index f00f73b919..50d35c682f 100644
--- a/import-layers/meta-openembedded/meta-oe/recipes-support/hwdata/hwdata_0.291.bb
+++ b/import-layers/meta-openembedded/meta-oe/recipes-support/hwdata/hwdata_git.bb
@@ -1,13 +1,15 @@
DESCRIPTION = "Hardware identification and configuration data"
-HOMEPAGE = "http://git.fedorahosted.org/git/hwdata.git"
+HOMEPAGE = "https://github.com/vcrhonek/hwdata"
SECTION = "System/Base"
LICENSE = "GPL-2.0+"
LIC_FILES_CHKSUM = "file://LICENSE;md5=1556547711e8246992b999edd9445a57"
-SRC_URI = "https://git.fedorahosted.org/cgit/${BPN}.git/snapshot/${BP}.tar.gz"
-SRC_URI[md5sum] = "90ffce584bbcb1a5e77eac8503949f71"
-SRC_URI[sha256sum] = "e1007a96645cb3390aa9c0ed3f090a69d2302ce4d801914b6af1ab4ec85ede4e"
+PV = "0.291+git${SRCPV}"
+SRCREV = "4bfbdcf5913d6dd53336d31b8035708075e6fdfa"
+SRC_URI = "git://github.com/vcrhonek/${BPN}.git"
+
+S = "${WORKDIR}/git"
do_configure() {
${S}/configure --datadir=${datadir} --libdir=${libdir}
diff --git a/import-layers/meta-openembedded/meta-oe/recipes-support/imagemagick/imagemagick_7.0.2.bb b/import-layers/meta-openembedded/meta-oe/recipes-support/imagemagick/imagemagick_7.0.2.bb
index 74fe369e94..cfaa7c3c68 100644
--- a/import-layers/meta-openembedded/meta-oe/recipes-support/imagemagick/imagemagick_7.0.2.bb
+++ b/import-layers/meta-openembedded/meta-oe/recipes-support/imagemagick/imagemagick_7.0.2.bb
@@ -20,7 +20,7 @@ inherit autotools pkgconfig update-alternatives
# xml disabled because it's using xml2-config --prefix to determine prefix which returns just /usr with our libxml2
# if someone needs xml support then fix it first
-EXTRA_OECONF = "--program-prefix= --program-suffix=.im6 --without-perl --disable-openmp --without-xml --disable-opencl"
+EXTRA_OECONF = "--program-prefix= --program-suffix=.im7 --without-perl --disable-openmp --without-xml --disable-opencl"
CACHED_CONFIGUREVARS = "ac_cv_sys_file_offset_bits=yes"
PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
@@ -51,40 +51,40 @@ ALTERNATIVE_PRIORITY = "100"
ALTERNATIVE_${PN} = "animate compare composite conjure convert display \
identify import mogrify montage stream"
-ALTERNATIVE_TARGET[animate] = "${bindir}/animate.im6"
-ALTERNATIVE_TARGET[compare] = "${bindir}/compare.im6"
-ALTERNATIVE_TARGET[composite] = "${bindir}/composite.im6"
-ALTERNATIVE_TARGET[conjure] = "${bindir}/conjure.im6"
-ALTERNATIVE_TARGET[convert] = "${bindir}/convert.im6"
-ALTERNATIVE_TARGET[display] = "${bindir}/display.im6"
-ALTERNATIVE_TARGET[identify] = "${bindir}/identify.im6"
-ALTERNATIVE_TARGET[import] = "${bindir}/import.im6"
-ALTERNATIVE_TARGET[mogrify] = "${bindir}/mogrify.im6"
-ALTERNATIVE_TARGET[montage] = "${bindir}/montage.im6"
-ALTERNATIVE_TARGET[stream] = "${bindir}/stream.im6"
+ALTERNATIVE_TARGET[animate] = "${bindir}/animate.im7"
+ALTERNATIVE_TARGET[compare] = "${bindir}/compare.im7"
+ALTERNATIVE_TARGET[composite] = "${bindir}/composite.im7"
+ALTERNATIVE_TARGET[conjure] = "${bindir}/conjure.im7"
+ALTERNATIVE_TARGET[convert] = "${bindir}/convert.im7"
+ALTERNATIVE_TARGET[display] = "${bindir}/display.im7"
+ALTERNATIVE_TARGET[identify] = "${bindir}/identify.im7"
+ALTERNATIVE_TARGET[import] = "${bindir}/import.im7"
+ALTERNATIVE_TARGET[mogrify] = "${bindir}/mogrify.im7"
+ALTERNATIVE_TARGET[montage] = "${bindir}/montage.im7"
+ALTERNATIVE_TARGET[stream] = "${bindir}/stream.im7"
ALTERNATIVE_${PN}-doc = "animate.1 compare.1 composite.1 conjure.1 \
convert.1 display.1 identify.1 import.1 mogrify.1 montage.1 stream.1"
ALTERNATIVE_LINK_NAME[animate.1] = "${mandir}/man1/animate.1"
-ALTERNATIVE_TARGET[animate.1] = "${mandir}/man1/animate.im6.1"
+ALTERNATIVE_TARGET[animate.1] = "${mandir}/man1/animate.im7.1"
ALTERNATIVE_LINK_NAME[compare.1] = "${mandir}/man1/compare.1"
-ALTERNATIVE_TARGET[compare.1] = "${mandir}/man1/compare.im6.1"
+ALTERNATIVE_TARGET[compare.1] = "${mandir}/man1/compare.im7.1"
ALTERNATIVE_LINK_NAME[composite.1] = "${mandir}/man1/composite.1"
-ALTERNATIVE_TARGET[composite.1] = "${mandir}/man1/composite.im6.1"
+ALTERNATIVE_TARGET[composite.1] = "${mandir}/man1/composite.im7.1"
ALTERNATIVE_LINK_NAME[conjure.1] = "${mandir}/man1/conjure.1"
-ALTERNATIVE_TARGET[conjure.1] = "${mandir}/man1/conjure.im6.1"
+ALTERNATIVE_TARGET[conjure.1] = "${mandir}/man1/conjure.im7.1"
ALTERNATIVE_LINK_NAME[convert.1] = "${mandir}/man1/convert.1"
-ALTERNATIVE_TARGET[convert.1] = "${mandir}/man1/convert.im6.1"
+ALTERNATIVE_TARGET[convert.1] = "${mandir}/man1/convert.im7.1"
ALTERNATIVE_LINK_NAME[display.1] = "${mandir}/man1/display.1"
-ALTERNATIVE_TARGET[display.1] = "${mandir}/man1/display.im6.1"
+ALTERNATIVE_TARGET[display.1] = "${mandir}/man1/display.im7.1"
ALTERNATIVE_LINK_NAME[identify.1] = "${mandir}/man1/identify.1"
-ALTERNATIVE_TARGET[identify.1] = "${mandir}/man1/identify.im6.1"
+ALTERNATIVE_TARGET[identify.1] = "${mandir}/man1/identify.im7.1"
ALTERNATIVE_LINK_NAME[import.1] = "${mandir}/man1/import.1"
-ALTERNATIVE_TARGET[import.1] = "${mandir}/man1/import.im6.1"
+ALTERNATIVE_TARGET[import.1] = "${mandir}/man1/import.im7.1"
ALTERNATIVE_LINK_NAME[mogrify.1] = "${mandir}/man1/mogrify.1"
-ALTERNATIVE_TARGET[mogrify.1] = "${mandir}/man1/mogrify.im6.1"
+ALTERNATIVE_TARGET[mogrify.1] = "${mandir}/man1/mogrify.im7.1"
ALTERNATIVE_LINK_NAME[montage.1] = "${mandir}/man1/montage.1"
-ALTERNATIVE_TARGET[montage.1] = "${mandir}/man1/montage.im6.1"
+ALTERNATIVE_TARGET[montage.1] = "${mandir}/man1/montage.im7.1"
ALTERNATIVE_LINK_NAME[stream.1] = "${mandir}/man1/stream.1"
-ALTERNATIVE_TARGET[stream.1] = "${mandir}/man1/stream.im6.1"
+ALTERNATIVE_TARGET[stream.1] = "${mandir}/man1/stream.im7.1"
diff --git a/import-layers/meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils/0001-Makefiles-Respect-environment-variables-and-add-LDFL.patch b/import-layers/meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils/0001-Makefiles-Respect-environment-variables-and-add-LDFL.patch
new file mode 100644
index 0000000000..9608b7e753
--- /dev/null
+++ b/import-layers/meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils/0001-Makefiles-Respect-environment-variables-and-add-LDFL.patch
@@ -0,0 +1,61 @@
+From 2cc2315eecaa48fd24792aaa889dc7d9fb96978b Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 20 Mar 2017 22:18:44 -0700
+Subject: [PATCH] Makefiles: Respect environment variables and add LDFLAGS to
+ linker cmdline
+
+Fixes QA errors about GNU_HASH
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ mib-modules/Makefile | 10 +++++-----
+ tools/Makefile | 2 +-
+ 2 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/mib-modules/Makefile b/mib-modules/Makefile
+index 0d54c9b..051d4d2 100644
+--- a/mib-modules/Makefile
++++ b/mib-modules/Makefile
+@@ -17,13 +17,13 @@ TARG = iscsiTargetMib.so
+ OBJS = iscsiTargetMib.o iscsiMib.o scsiMib.o ipsAuthMib.o \
+ iscsiAuthData.o
+
+-CC = gcc
+-CFLAGS = -I$(INCLDIR) -I$(INCLDIR)/agent -I$(INCLDIR)/agent/mibgroup -shared -fPIC
++CC ?= gcc
++CFLAGS += -I$(INCLDIR) -I$(INCLDIR)/agent -I$(INCLDIR)/agent/mibgroup -shared -fPIC
+ CFLAGS += -I../include -Wall -Werror
+ #CFLAGS +=$(AUTO_CFLAGS)
+
+-LD = gcc -shared
+-
++LD ?= gcc
++LDFLAGS += -shared
+ INSTALL = install
+
+ all: $(TARG)
+@@ -32,7 +32,7 @@ all: $(TARG)
+ $(CC) $(CFLAGS) -o $@ -c $<
+
+ $(TARG): $(OBJS)
+- $(LD) -o $@ $(OBJS)
++ $(LD) -o $@ $(OBJS) $(LDFLAGS)
+
+ clean:
+ rm -f $(OBJS) $(TARG)
+diff --git a/tools/Makefile b/tools/Makefile
+index 79ed3cd..ffd9bf3 100644
+--- a/tools/Makefile
++++ b/tools/Makefile
+@@ -6,7 +6,7 @@ ISCSI_NAME_OBJS = $(ISCSI_NAME_SRCS:.c=.o)
+ all:: $(ISCSI_NAME)
+
+ $(ISCSI_NAME): $(ISCSI_NAME_OBJS)
+- $(CC) -o $@ $(CFLAGS) $(ISCSI_NAME_OBJS)
++ $(CC) -o $@ $(CFLAGS) $(LDFLAGS) $(ISCSI_NAME_OBJS)
+
+ clean:
+ rm -f $(ISCSI_NAME_OBJS) $(ISCSI_NAME)
+--
+2.12.0
+
diff --git a/import-layers/meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb b/import-layers/meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb
index 35ba16141f..3a6319c314 100644
--- a/import-layers/meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb
+++ b/import-layers/meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb
@@ -6,7 +6,9 @@ LIC_FILES_CHKSUM = "file://debian/copyright;md5=c3ea231a32635cbb5debedf3e88aa3df
PV = "4.1+git${SRCPV}"
-SRC_URI = "git://risingtidesystems.com/lio-utils.git"
+SRC_URI = "git://risingtidesystems.com/lio-utils.git \
+ file://0001-Makefiles-Respect-environment-variables-and-add-LDFL.patch \
+ "
SRCREV = "28bd928655bdc7bd3cf380f0196630690c51e05f"
S = "${WORKDIR}/git"
diff --git a/import-layers/meta-openembedded/meta-oe/recipes-support/lm_sensors/lmsensors_3.4.0.bb b/import-layers/meta-openembedded/meta-oe/recipes-support/lm_sensors/lmsensors_3.4.0.bb
index 8215d90a8e..dbc05a898d 100644
--- a/import-layers/meta-openembedded/meta-oe/recipes-support/lm_sensors/lmsensors_3.4.0.bb
+++ b/import-layers/meta-openembedded/meta-oe/recipes-support/lm_sensors/lmsensors_3.4.0.bb
@@ -7,13 +7,13 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
DEPENDS = "sysfsutils virtual/libiconv bison-native flex-native rrdtool"
-SRC_URI = "http://dl.lm-sensors.org/lm-sensors/releases/lm_sensors-${PV}.tar.bz2 \
+SRC_URI = "https://github.com/groeck/lm-sensors/archive/V3-4-0.tar.gz \
file://fancontrol.init \
file://sensord.init \
file://0001-lmsensors-sensors-detect-print-a-special-message-whe.patch \
"
-SRC_URI[md5sum] = "c03675ae9d43d60322110c679416901a"
-SRC_URI[sha256sum] = "e0579016081a262dd23eafe1d22b41ebde78921e73a1dcef71e05e424340061f"
+SRC_URI[md5sum] = "1e9f117cbfa11be1955adc96df71eadb"
+SRC_URI[sha256sum] = "e334c1c2b06f7290e3e66bdae330a5d36054701ffd47a5dde7a06f9a7402cb4e"
inherit update-rc.d systemd
@@ -29,7 +29,7 @@ SYSTEMD_PACKAGES = "${PN}-sensord"
SYSTEMD_SERVICE_${PN}-sensord = "sensord.service lm_sensors.service fancontrol.service"
SYSTEMD_AUTO_ENABLE = "disable"
-S = "${WORKDIR}/lm_sensors-${PV}"
+S = "${WORKDIR}/lm-sensors-3-4-0"
EXTRA_OEMAKE = 'EXLDFLAGS="${LDFLAGS}" \
MACHINE=${TARGET_ARCH} PREFIX=${prefix} MANDIR=${mandir} \
diff --git a/import-layers/meta-openembedded/meta-oe/recipes-support/mailcap/mailcap_2.1.46.bb b/import-layers/meta-openembedded/meta-oe/recipes-support/mailcap/mailcap_2.1.46.bb
index 7d87a5f1d2..58b8f029ea 100644
--- a/import-layers/meta-openembedded/meta-oe/recipes-support/mailcap/mailcap_2.1.46.bb
+++ b/import-layers/meta-openembedded/meta-oe/recipes-support/mailcap/mailcap_2.1.46.bb
@@ -12,12 +12,14 @@ by several applications e.g. to determine MIME types for filenames."
SECTION = "System Environment/Base"
-SRC_URI = "https://git.fedorahosted.org/cgit/${BPN}.git/snapshot/${BPN}-r2-1-46.tar.gz"
-SRC_URI[md5sum] = "eee03824bf86480dc1db20be4f78237f"
-SRC_URI[sha256sum] = "309059163fa3ef368f8a43fc38f7a45d9345fd725970d5b437ba175a0ee7ebc9"
LICENSE = "PD & MIT"
LIC_FILES_CHKSUM = "file://COPYING;md5=100fcfb84512ccc03ffc7d89ac391305"
-S = "${WORKDIR}/${BPN}-r2-1-46"
+
+SRC_URI = "https://releases.pagure.org/${BPN}/${BP}.tar.xz"
+
+SRC_URI[md5sum] = "d865a1baf574ae5d309f5c1f79315800"
+SRC_URI[sha256sum] = "c68eb3b531d731476d5980c9b7cc287bd64c2a13bec5a537009a2c4af63f9bb0"
+
do_install() {
oe_runmake install DESTDIR=${D} sysconfdir=${sysconfdir} mandir=${mandir}
}
diff --git a/import-layers/meta-openembedded/meta-oe/recipes-support/picocom/picocom_1.7.bb b/import-layers/meta-openembedded/meta-oe/recipes-support/picocom/picocom_1.7.bb
index dbee656098..d2a76c0a94 100644
--- a/import-layers/meta-openembedded/meta-oe/recipes-support/picocom/picocom_1.7.bb
+++ b/import-layers/meta-openembedded/meta-oe/recipes-support/picocom/picocom_1.7.bb
@@ -9,7 +9,8 @@ SRC_URI = "http://picocom.googlecode.com/files/picocom-${PV}.tar.gz"
SRC_URI[md5sum] = "8eaba1d31407e8408674d6e57af447ef"
SRC_URI[sha256sum] = "d0f31c8f7a215a76922d30c81a52b9a2348c89e02a84935517002b3bc2c1129e"
-CPPFLAGS_append = '-DVERSION_STR=\\"${PV}\\" -DUUCP_LOCK_DIR=\\"/var/lock\\" -DHIGH_BAUD'
+EXTRA_OEMAKE = "'CC=${CC}' 'LD=${LD}' 'VERSION=${PV}' \
+ 'CFLAGS=${CFLAGS}' 'LDFLAGS=${LDFLAGS}' "
do_install () {
install -d ${D}${bindir}
diff --git a/import-layers/meta-openembedded/meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb b/import-layers/meta-openembedded/meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb
index d523b7a8f5..6d0dfff930 100644
--- a/import-layers/meta-openembedded/meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb
+++ b/import-layers/meta-openembedded/meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb
@@ -12,7 +12,7 @@ SRC_URI[sha256sum] = "77f0a039ac64df55fbd06af6f872fdbad4f639d009bbb5cd5cbe4db256
EXTRA_OEMAKE = "-e MAKEFLAGS="
do_compile() {
- oe_runmake -f Makefile.unx INCS=-I${STAGING_DIR_HOST}${incdir} LIBS=${STAGING_DIR_HOST}${libdir}/libz.a
+ oe_runmake -f Makefile.unx INCS=-I${STAGING_DIR_HOST}${incdir} LIBS='${STAGING_DIR_HOST}${libdir}/libz.a ${LDFLAGS}'
}
do_install() {
diff --git a/import-layers/meta-openembedded/meta-oe/recipes-support/procmail/procmail_3.22.bb b/import-layers/meta-openembedded/meta-oe/recipes-support/procmail/procmail_3.22.bb
index 1063654f5c..56656c42a9 100644
--- a/import-layers/meta-openembedded/meta-oe/recipes-support/procmail/procmail_3.22.bb
+++ b/import-layers/meta-openembedded/meta-oe/recipes-support/procmail/procmail_3.22.bb
@@ -29,11 +29,11 @@ do_configure() {
export CFLAGS="${BUILD_CFLAGS}"
export AR="${BUILD_AR}"
export AS="${BUILD_AS}"
- make TARGET_CFLAGS="$TARGET_CFLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64" autoconf.h
+ make TARGET_CFLAGS="$TARGET_CFLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64" LDFLAGS0="${LDFLAGS}" autoconf.h
}
do_compile() {
- oe_runmake -i TARGET_CFLAGS="$TARGET_CFLAGS -Wno-comments -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
+ oe_runmake -i TARGET_CFLAGS="$TARGET_CFLAGS -Wno-comments -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64" LDFLAGS0="${LDFLAGS}"
}
do_install() {
diff --git a/import-layers/meta-openembedded/meta-oe/recipes-support/zile/zile_2.4.11.bb b/import-layers/meta-openembedded/meta-oe/recipes-support/zile/zile_2.4.11.bb
index b3f191861e..49fbaead66 100644
--- a/import-layers/meta-openembedded/meta-oe/recipes-support/zile/zile_2.4.11.bb
+++ b/import-layers/meta-openembedded/meta-oe/recipes-support/zile/zile_2.4.11.bb
@@ -14,6 +14,11 @@ SRC_URI[sha256sum] = "1fd27bbddc61491b1fbb29a345d0d344734aa9e80cfa07b02892eedf83
inherit autotools pkgconfig
+do_install_append() {
+ rm -rf ${D}${libdir}/charset.alias
+ rmdir --ignore-fail-on-non-empty ${D}${libdir} || true
+}
+
PACKAGECONFIG ??= ""
PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}"