summaryrefslogtreecommitdiff
path: root/meta-amd/recipes-phosphor/console
diff options
context:
space:
mode:
authorKonstantin Aladyshev <aladyshev22@gmail.com>2023-04-10 11:28:08 +0300
committerKonstantin Aladyshev <aladyshev22@gmail.com>2023-04-10 14:30:03 +0300
commitb81319839fb55133d11cf27b8419ceead1f530cc (patch)
tree8589c04b605eb7cc9b0f321d286cee2e1446c4e2 /meta-amd/recipes-phosphor/console
parent90e792a45ac1ca2fbd237df40212308abe90c09f (diff)
downloadopenbmc-b81319839fb55133d11cf27b8419ceead1f530cc.tar.xz
meta-amd: Use correct syntax to append SRC_URI on override
'SRC_URI:<machine> +=' syntax creates new variable 'SRC_URI:<machine>'. 'SRC_URI:append:<machine> =' syntax appends the variable 'SRC_URI' when appropriate machine is selected. hostlogger and obmc-console recipes incorrectly use the first syntax in places where they should use the second one. This leads to build error, when bitbake can't find added files. Correct recipes to fix ethanolx/daytonax boards build. Change-Id: Ibf424b95ae5aadf4c2ffd5915d746fb19f2a6d66 Signed-off-by: Konstantin Aladyshev <aladyshev22@gmail.com>
Diffstat (limited to 'meta-amd/recipes-phosphor/console')
-rw-r--r--meta-amd/recipes-phosphor/console/obmc-console_%.bbappend4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-amd/recipes-phosphor/console/obmc-console_%.bbappend b/meta-amd/recipes-phosphor/console/obmc-console_%.bbappend
index 1b0e753a8f..8ffa93b689 100644
--- a/meta-amd/recipes-phosphor/console/obmc-console_%.bbappend
+++ b/meta-amd/recipes-phosphor/console/obmc-console_%.bbappend
@@ -3,8 +3,8 @@ OBMC_CONSOLE_HOST_TTY:ethanolx = "ttyS0"
OBMC_CONSOLE_HOST_TTY:daytonax = "ttyVUART0"
SRC_URI:remove = "file://${BPN}.conf"
-SRC_URI:ethanolx += "file://server.ttyS0.conf"
-SRC_URI:daytonax += "file://server.ttyVUART0.conf"
+SRC_URI:append:ethanolx = " file://server.ttyS0.conf"
+SRC_URI:append:daytonax = " file://server.ttyVUART0.conf"
do_install:append() {
# Remove upstream-provided configuration