summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ssif_%.bbappend
diff options
context:
space:
mode:
authorThu Nguyen <thu@os.amperecomputing.com>2023-07-12 07:59:14 +0300
committerThang Q. Nguyen <thang@os.amperecomputing.com>2023-10-16 17:00:19 +0300
commite50b26fd6fbcb499196ff84f46a8ca5d14f951a7 (patch)
tree2591f4470e74508850935f3389486fd444b9fc2f /meta-ampere/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ssif_%.bbappend
parent657613a73ca51fd4fc3c335bb443e8527be2e0c8 (diff)
downloadopenbmc-e50b26fd6fbcb499196ff84f46a8ca5d14f951a7.tar.xz
meta-ampere: mtjade: update scripts with new gpio linename
Mt.Jade GPIO line-names are updated to follow naming convention at https://github.com/openbmc/docs/blob/master/designs/device-tree-gpio-naming.md. This commit updates related scripts to use the correct linenames. Tested: Check below features to work as before: + UEFI and SCP firmware update. + Host power control + Ampere UART mux switch + SCP failover Signed-off-by: Thu Nguyen <thu@os.amperecomputing.com> Change-Id: I080f844047618327042a7742d3fa6423b62be744
Diffstat (limited to 'meta-ampere/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ssif_%.bbappend')
-rw-r--r--meta-ampere/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ssif_%.bbappend11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-ampere/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ssif_%.bbappend b/meta-ampere/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ssif_%.bbappend
new file mode 100644
index 0000000000..e03cc21fb7
--- /dev/null
+++ b/meta-ampere/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-ssif_%.bbappend
@@ -0,0 +1,11 @@
+FILESEXTRAPATHS:append := "${THISDIR}/${PN}:"
+
+SRC_URI += " file://ssifbridge-override.conf"
+
+FILES:${PN} += "${systemd_system_unitdir}/ssifbridge.service.d"
+
+do_install:append() {
+ install -d ${D}${systemd_system_unitdir}/ssifbridge.service.d
+ install -m 644 ${WORKDIR}/ssifbridge-override.conf \
+ ${D}${systemd_system_unitdir}/ssifbridge.service.d
+}