summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-common
diff options
context:
space:
mode:
authorThang Tran <thuutran@amperecomputing.com>2023-05-12 10:50:30 +0300
committerThang Q. Nguyen <thang@os.amperecomputing.com>2023-05-12 11:36:12 +0300
commit06b5ffd92f0eb9a43aad3bb2ed07cdd0ecea3321 (patch)
treef3acac4bdc3040e17172ac4cadf79589294eb484 /meta-ampere/meta-common
parent7298c40df4b8c330313716077ac25518e1aa5799 (diff)
downloadopenbmc-06b5ffd92f0eb9a43aad3bb2ed07cdd0ecea3321.tar.xz
meta-ampere: state: enable checkACLoss while recovering
Commit phosphor-state-manager@e960184 corrects the code logic that relates to only-run-apr-on-power-loss option build. Users have to set only-run-apr-on-power-loss=true to enable checking AC loss while recovering Host. This commit enables this option. Tested: 1. Set chassis policy to always-on. $ipmitool chassis policy always-on 2. Power off the HOST $ipmitool power off 3. AC power. 4. Host is turned on after BMC has been rebooted 5. Set chassis policy to always-off. $ipmitool chassis policy always-off 6. Power on the HOST $ipmitool power on 7. AC power. 8. Host is turned off after BMC has been rebooted 9. Set chassis policy to previous $ipmitool chassis policy previous 10. Power off the HOST $ipmitool power ff 11. AC power. 12. Host is turned off after BMC has been rebooted 13. Power on the HOST $ipmitool power on 14. AC power. 15. Host is turned on after BMC has been rebooted Change-Id: Ic7bdcdfebc0df415232fc2677e464cca3f341366 Signed-off-by: Thang Tran <thuutran@amperecomputing.com>
Diffstat (limited to 'meta-ampere/meta-common')
-rw-r--r--meta-ampere/meta-common/recipes-phosphor/state/phosphor-state-manager_%.bbappend1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-ampere/meta-common/recipes-phosphor/state/phosphor-state-manager_%.bbappend b/meta-ampere/meta-common/recipes-phosphor/state/phosphor-state-manager_%.bbappend
index 62c6f96805..74c1ba8ebf 100644
--- a/meta-ampere/meta-common/recipes-phosphor/state/phosphor-state-manager_%.bbappend
+++ b/meta-ampere/meta-common/recipes-phosphor/state/phosphor-state-manager_%.bbappend
@@ -5,6 +5,7 @@ DEPENDS += "gpioplus libgpiod"
EXTRA_OEMESON:append = " \
-Dhost-gpios=enabled \
-Dboot-count-max-allowed=1 \
+ -Donly-run-apr-on-power-loss=true \
"
FILES:${PN} += "${systemd_system_unitdir}/*"