summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-common
diff options
context:
space:
mode:
authorThang Q. Nguyen <thang@os.amperecomputing.com>2024-06-27 05:17:42 +0300
committerThang Q. Nguyen <thang@os.amperecomputing.com>2024-07-02 06:14:09 +0300
commit4a3fcf017a4653f605b901869d0c9b163d91e8fd (patch)
tree9a6afe25a4611a36fd57ddd0516ab898c0d3a635 /meta-ampere/meta-common
parent24adf7e49a73aa85ccc2e0f97b334c6fefac3412 (diff)
downloadopenbmc-4a3fcf017a4653f605b901869d0c9b163d91e8fd.tar.xz
meta-ampere: redfish: remove Chassis/chassis instance
The /xyz/openbmc_project/inventory/system/chassis interface was added before for sensor report and other features that phosphor-inventory-manager. With latest approach, it is no longer needed so this commit removes it. The redundant Redfish Chassis/chassis instance is removed. Tested: 1. Check Redfish /redfish/v1/Chassis without 'chassis' instance. Change-Id: I4724f3c07a5b90d286aa6945d6714ea356868ebe Signed-off-by: Thang Q. Nguyen <thang@os.amperecomputing.com>
Diffstat (limited to 'meta-ampere/meta-common')
-rw-r--r--meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup.bb17
-rw-r--r--meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup/inventory-cleanup.yaml16
2 files changed, 0 insertions, 33 deletions
diff --git a/meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup.bb b/meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup.bb
deleted file mode 100644
index 1b5a119b1b..0000000000
--- a/meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-SUMMARY = "Copy the inventory cleanup yaml for inventory manager"
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit allarch
-inherit phosphor-inventory-manager
-
-S = "${WORKDIR}"
-
-SRC_URI = "file://inventory-cleanup.yaml"
-
-do_install() {
- install -D inventory-cleanup.yaml ${D}${base_datadir}/events.d/inventory-cleanup.yaml
-}
-
-FILES:${PN} += "${base_datadir}/events.d/inventory-cleanup.yaml"
diff --git a/meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup/inventory-cleanup.yaml b/meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup/inventory-cleanup.yaml
deleted file mode 100644
index 23f54e3319..0000000000
--- a/meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup/inventory-cleanup.yaml
+++ /dev/null
@@ -1,16 +0,0 @@
-description: >
- Ampere inventory fixups
-
-events:
- - name: Add Chassis interface
- description: >
- Add the chassis interface on the chassis inventory path
- type: startup
- actions:
- - name: createObjects
- objs:
- /system/chassis:
- xyz.openbmc_project.Inventory.Item.Chassis:
- Type:
- value: "xyz.openbmc_project.Inventory.Item.Chassis.ChassisType.RackMount"
- type: string