summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-common
diff options
context:
space:
mode:
authorChau Ly <chaul@amperecomputing.com>2023-02-03 11:06:16 +0300
committerChau Ly <chaul@amperecomputing.com>2023-03-15 05:55:05 +0300
commit5aa54cdd75092d88ed6df95b30364024694fdbac (patch)
treeed3b520bf2ddecfac68a6535a4fbaf0fce2d8158 /meta-ampere/meta-common
parent512479e0f0e749db22175cc2feb12fdebe50a9b5 (diff)
downloadopenbmc-5aa54cdd75092d88ed6df95b30364024694fdbac.tar.xz
meta-ampere: phosphor-fan: Use monitor package configurations
This commit enables package configurations delay-host-control=20 and monitor-use-host-state, in order to delay and rescan before turning host off when fan sensors are not detected after power state changes from Off to On; and use CurrentHostState to decide host state for phosphor-fan-monitor instead of pgood state. Tested: 1. Host is ON, reboot BMC => Host is not turned off unexpectedly during BMC boot up 2. Power cycle host => fan sensors are not marked as non-functional Signed-off-by: Chau Ly <chaul@amperecomputing.com> Change-Id: Iea6ed195a42e41bee23066e670b67c19bcfda722
Diffstat (limited to 'meta-ampere/meta-common')
-rw-r--r--meta-ampere/meta-common/recipes-phosphor/fans/phosphor-fan_%.bbappend8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-ampere/meta-common/recipes-phosphor/fans/phosphor-fan_%.bbappend b/meta-ampere/meta-common/recipes-phosphor/fans/phosphor-fan_%.bbappend
new file mode 100644
index 0000000000..5a3a67826c
--- /dev/null
+++ b/meta-ampere/meta-common/recipes-phosphor/fans/phosphor-fan_%.bbappend
@@ -0,0 +1,8 @@
+FILESEXTRAPATHS:append := "${THISDIR}/${PN}:"
+
+# To delay turning off host when fan sensors are not detected yet
+# To use CurrentHostState to decide host state for phosphor-fan-monitor
+
+PACKAGECONFIG:append = " delay-host-control monitor-use-host-state"
+PACKAGECONFIG[delay-host-control] = "-Ddelay-host-control=20"
+PACKAGECONFIG[monitor-use-host-state] = "-Dmonitor-use-host-state=enabled"