summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-jade/recipes-phosphor
diff options
context:
space:
mode:
authorChau Ly <chaul@amperecomputing.com>2024-01-29 12:40:12 +0300
committerChau Ly <chaul@amperecomputing.com>2024-01-30 06:49:22 +0300
commit4dfb3270aef32733d5d2472e0d0832f2f35524ad (patch)
tree12751588a2259265fbb4d710db9bc5bab38b0e16 /meta-ampere/meta-jade/recipes-phosphor
parent94e479869b113c2642de28a3dc46e393279ff242 (diff)
downloadopenbmc-4dfb3270aef32733d5d2472e0d0832f2f35524ad.tar.xz
meta-ampere: Remove uart-mux control scripts
This commit removes support for controlling uart muxes from Host. The uart muxes will now be default to connect to BMC on AC/DC. This therefore can remove all the mux control scripts in obmc-console recipe. Tested: Upon BMC AC/DC Can successfully ssh to Host's uart consoles via BMC's IP Example: ssh root@<BMC_IP> -p 2200 Signed-off-by: Chau Ly <chaul@amperecomputing.com> Change-Id: Ia4f421956f182dcb5d8e2e2ef8cb4eb404a15f2d
Diffstat (limited to 'meta-ampere/meta-jade/recipes-phosphor')
-rw-r--r--meta-ampere/meta-jade/recipes-phosphor/console/obmc-console/ampere_uart_console_setup.sh30
-rw-r--r--meta-ampere/meta-jade/recipes-phosphor/console/obmc-console_%.bbappend4
2 files changed, 0 insertions, 34 deletions
diff --git a/meta-ampere/meta-jade/recipes-phosphor/console/obmc-console/ampere_uart_console_setup.sh b/meta-ampere/meta-jade/recipes-phosphor/console/obmc-console/ampere_uart_console_setup.sh
deleted file mode 100644
index 5a48d49ea5..0000000000
--- a/meta-ampere/meta-jade/recipes-phosphor/console/obmc-console/ampere_uart_console_setup.sh
+++ /dev/null
@@ -1,30 +0,0 @@
-#!/bin/sh -e
-#
-# Platform can add tty ports for console server to OBMC_CONSOLE_TTYS in their
-# bbappend. The target tty devices exposed by kernel will then start their
-# corresponding obmc-console-server instance and the
-# obmc-console@<tty-port>.service will execute this script to direct the uart
-# port of the <tty-port> to BMC
-
-tty="$1"
-uart=0
-
-case "${tty}" in
- "ttyS0") uart=1
- ;;
- "ttyS1") uart=2
- ;;
- "ttyS2") uart=3
- ;;
- "ttyS3") uart=4
- ;;
- *) echo "Invalid tty passed to $0. Exiting!"
- exit 0;
- ;;
-esac
-
-# Default the host routing through the mux to use the BMC (2)
-# This allows the SoL console in webui, and the ssh port 2200, to work
-# upon startup. If UART transcievers are installed on the header and required,
-# this value should be set to 1
-/usr/sbin/ampere_uartmux_ctrl.sh ${uart} 2
diff --git a/meta-ampere/meta-jade/recipes-phosphor/console/obmc-console_%.bbappend b/meta-ampere/meta-jade/recipes-phosphor/console/obmc-console_%.bbappend
index bd75de6292..77cd4b9606 100644
--- a/meta-ampere/meta-jade/recipes-phosphor/console/obmc-console_%.bbappend
+++ b/meta-ampere/meta-jade/recipes-phosphor/console/obmc-console_%.bbappend
@@ -8,7 +8,6 @@ CONSOLE_CLIENT = "2200 2201 2202 2203"
SRC_URI += " \
${@compose_list(d, 'CONSOLE_SERVER_CONF_FMT', 'OBMC_CONSOLE_TTYS')} \
${@compose_list(d, 'CONSOLE_CLIENT_CONF_FMT', 'CONSOLE_CLIENT')} \
- file://ampere_uart_console_setup.sh \
"
SYSTEMD_SERVICE:${PN}:append = " \
@@ -16,9 +15,6 @@ SYSTEMD_SERVICE:${PN}:append = " \
"
do_install:append() {
- # Script to set host's uart muxes to BMC
- install -m 0755 ${WORKDIR}/ampere_uart_console_setup.sh ${D}${sbindir}
-
# Install the console client configurations
install -m 0644 ${WORKDIR}/client.*.conf ${D}${sysconfdir}/${BPN}
}